summaryrefslogtreecommitdiff
path: root/user/libnl3
diff options
context:
space:
mode:
Diffstat (limited to 'user/libnl3')
-rw-r--r--user/libnl3/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/user/libnl3/APKBUILD b/user/libnl3/APKBUILD
index 58dc88d4e..f5a2e5668 100644
--- a/user/libnl3/APKBUILD
+++ b/user/libnl3/APKBUILD
@@ -1,6 +1,7 @@
# Maintainer:
pkgname=libnl3
pkgver=3.2.28
+_pkgver=$(printf '%s' "$pkgver" | tr . _)
pkgrel=2
pkgdesc="Library for applications dealing with netlink sockets"
url="http://www.infradead.org/~tgr/libnl/"
@@ -10,8 +11,8 @@ depends=""
makedepends="linux-headers flex bison"
checkdepends="check-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-cli"
-source="https://github.com/thom311/libnl/releases/download/libnl${pkgver//./_}/libnl-$pkgver.tar.gz"
-builddir="$srcdir"/libnl-$pkgver
+source="https://github.com/thom311/libnl/releases/download/libnl$_pkgver/libnl-$pkgver.tar.gz"
+builddir="$srcdir/libnl-$pkgver"
build() {
cd "$builddir"