summaryrefslogtreecommitdiff
path: root/user/liborcus
diff options
context:
space:
mode:
Diffstat (limited to 'user/liborcus')
-rw-r--r--user/liborcus/APKBUILD12
-rw-r--r--user/liborcus/sepples-is-a-sin.patch11
2 files changed, 19 insertions, 4 deletions
diff --git a/user/liborcus/APKBUILD b/user/liborcus/APKBUILD
index 3f0434eae..378ff6bbd 100644
--- a/user/liborcus/APKBUILD
+++ b/user/liborcus/APKBUILD
@@ -1,16 +1,19 @@
# Contributor: Timo Teräs <timo.teras@iki.fi>
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=liborcus
-pkgver=0.14.1
+pkgver=0.15.3
pkgrel=0
pkgdesc="Library for processing spreadsheet documents"
url="https://gitlab.com/orcus/orcus"
arch="all"
license="MPL-2.0 AND MIT"
-depends_dev="boost-dev mdds~1.4 libixion-dev~0.14"
+depends=""
+depends_dev="boost-dev mdds~1.5 libixion-dev~0.15"
makedepends="$depends_dev zlib-dev"
subpackages="$pkgname-dev"
-source="http://kohei.us/files/orcus/src/$pkgname-$pkgver.tar.xz"
+source="http://kohei.us/files/orcus/src/$pkgname-$pkgver.tar.xz
+ sepples-is-a-sin.patch
+ "
build() {
./configure \
@@ -32,4 +35,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="a32dc5a652ce99cff37273c38fb9460e13e7bfb562f40c8d0c79b65c33e340daaeeb2c796308ca700b85bfc13cc8215641563b9e9f6d44b7d61adb8e8a3c950f liborcus-0.14.1.tar.xz"
+sha512sums="bb5495a64ac5f984e107feb36dfe5c801d2ce7e2fcbee8f8bc779d87001e1fcb1d1f70ee2695eb976f1553c59908a15f887ceeb7ccfc556d4476ea846c5036f2 liborcus-0.15.3.tar.xz
+a5eca9d173942926a2c2469b9a40099ae22f42e11c44590045b126c1acca07aedbf27af7ae336ae6f6e1271036f795ead0ca00e77e53c67581ed4c387600f9a9 sepples-is-a-sin.patch"
diff --git a/user/liborcus/sepples-is-a-sin.patch b/user/liborcus/sepples-is-a-sin.patch
new file mode 100644
index 000000000..210ef2c86
--- /dev/null
+++ b/user/liborcus/sepples-is-a-sin.patch
@@ -0,0 +1,11 @@
+--- liborcus-0.15.3/src/liborcus/json_map_tree.cpp 2019-08-02 19:31:14.000000000 -0400
++++ liborcus-0.15.3/src/liborcus/json_map_tree.cpp 2020-02-06 23:35:09.274550724 -0500
+@@ -14,6 +14,8 @@
+
+ namespace orcus {
+
++constexpr json_map_tree::child_position_type json_map_tree::node_child_default_position;
++
+ namespace {
+
+ void throw_path_error(const char* file, int line, const pstring& path)