summaryrefslogtreecommitdiff
path: root/user/libotr/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/libotr/APKBUILD')
-rw-r--r--user/libotr/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/user/libotr/APKBUILD b/user/libotr/APKBUILD
new file mode 100644
index 000000000..98c18ffff
--- /dev/null
+++ b/user/libotr/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=libotr
+pkgver=4.1.1
+pkgrel=0
+pkgdesc="Messaging library for secure, encrypted communications"
+url="https://otr.cypherpunks.ca/"
+arch="all"
+license="LGPL-2.1-only"
+depends=""
+depends_dev="libgcrypt-dev libgpg-error-dev"
+makedepends="$depends_dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://otr.cypherpunks.ca/libotr-$pkgver.tar.gz
+ fix-test.patch
+ "
+
+prepare() {
+ default_prepare
+ update_config_sub
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="c957206235b9f627542f23a645c822ea1b318d83fa655f41ed8d9a3c0dddf30b88f0ca82060026af155e48ecb13969dc9270831f20304669794151f666ae5cb0 libotr-4.1.1.tar.gz
+dcd1e55619b2ef51f14257cddcceb5f1b850da42c2acb7547713256a377df60d30591d06522fe6982db8c261687f1f18640a1ffaaf1c701d9356bd97dab1d8c8 fix-test.patch"