summaryrefslogtreecommitdiff
path: root/user/libpng/libpng-fix-arm-neon.patch
diff options
context:
space:
mode:
Diffstat (limited to 'user/libpng/libpng-fix-arm-neon.patch')
-rw-r--r--user/libpng/libpng-fix-arm-neon.patch8
1 files changed, 6 insertions, 2 deletions
diff --git a/user/libpng/libpng-fix-arm-neon.patch b/user/libpng/libpng-fix-arm-neon.patch
index 2cd3f18c2..099083fd9 100644
--- a/user/libpng/libpng-fix-arm-neon.patch
+++ b/user/libpng/libpng-fix-arm-neon.patch
@@ -1,6 +1,8 @@
+diff --git a/configure.ac b/configure.ac
+index 7b6d5b9..d02e16d 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -364,17 +364,21 @@
+@@ -357,17 +357,21 @@ AC_ARG_ENABLE([arm-neon],
[case "$enableval" in
no|off)
# disable the default enabling on __ARM_NEON__ systems:
@@ -8,7 +10,7 @@
AC_DEFINE([PNG_ARM_NEON_OPT], [0],
[Disable ARM Neon optimizations])
# Prevent inclusion of the assembler files below:
- enable_arm_neon=no;;
+ enable_arm_neon=no ;;
check)
+ AC_DEFINE([PNG_ARM_NEON], [], [ARM NEON support])
AC_DEFINE([PNG_ARM_NEON_CHECK_SUPPORTED], [],
@@ -22,6 +24,8 @@
AC_DEFINE([PNG_ARM_NEON_OPT], [2],
[Enable ARM Neon optimizations])
AC_MSG_WARN([--enable-arm-neon: please specify 'check' or 'api', if]
+diff --git a/pngpriv.h b/pngpriv.h
+index 2e426cf..fb521cf 100644
--- a/pngpriv.h
+++ b/pngpriv.h
@@ -127,7 +127,7 @@