summaryrefslogtreecommitdiff
path: root/user/libqxp/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/libqxp/APKBUILD')
-rw-r--r--user/libqxp/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/user/libqxp/APKBUILD b/user/libqxp/APKBUILD
new file mode 100644
index 000000000..de0a29d66
--- /dev/null
+++ b/user/libqxp/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname=libqxp
+pkgver=0.0.1
+pkgrel=0
+pkgdesc="Import filter and tools for QuarkXPress documents"
+url="https://wiki.documentfoundation.org/DLP/Libraries/libqxp"
+arch="all"
+license="MPL-2.0"
+depends=""
+depends_dev="librevenge-dev"
+makedepends="$depends_dev icu-dev doxygen"
+checkdepends="cppunit-dev"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-tools"
+source="https://dev-www.libreoffice.org/src/$pkgname/$pkgname-$pkgver.tar.xz"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ make
+ cd "$builddir/docs"
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+tools() {
+ mkdir -p "$subpkgdir"/usr
+ mv "$pkgdir"/usr/bin "$subpkgdir"/usr
+}
+
+sha512sums="a03a9ada658a92f4d985cad91d467b3916334c74dc26c1e4de89e3929e0135ca0e9c7e7e18ce616ef56a67863ec19c2638494400785849017f9a4776df07c607 libqxp-0.0.1.tar.xz"