summaryrefslogtreecommitdiff
path: root/user/libreoffice/gettext-tiny.patch
diff options
context:
space:
mode:
Diffstat (limited to 'user/libreoffice/gettext-tiny.patch')
-rw-r--r--user/libreoffice/gettext-tiny.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/user/libreoffice/gettext-tiny.patch b/user/libreoffice/gettext-tiny.patch
new file mode 100644
index 000000000..990241c3b
--- /dev/null
+++ b/user/libreoffice/gettext-tiny.patch
@@ -0,0 +1,38 @@
+gettext-tiny does not currently ship msguniq, so let's cheat around it
+
+--- libreoffice-6.0.6.2/solenv/gbuild/AllLangMoTarget.mk
++++ libreoffice-6.0.6.2/solenv/gbuild/AllLangMoTarget.mk
+@@ -40,10 +40,10 @@
+ $(call gb_Helper_abbreviate_dirs,\
+ mkdir -p $(dir $@) && \
+ if test -e $(gb_POLOCATION)/$(LANGUAGE)/$(POLOCATION)/messages.po; then \
+- $(MSGUNIQ) --force-po $(gb_POLOCATION)/$(LANGUAGE)/$(POLOCATION)/messages.po | $(MSGFMT) - -o $@; \
++ cat $(gb_POLOCATION)/$(LANGUAGE)/$(POLOCATION)/messages.po | $(MSGFMT) - -o $@; \
+ else \
+ echo missing $(gb_POLOCATION)/$(LANGUAGE)/$(POLOCATION)/messages.po && \
+- $(MSGUNIQ) --force-po $(SRCDIR)/solenv/bin/dummy.po | $(MSGFMT) - -o $@; \
++ cat $(SRCDIR)/solenv/bin/dummy.po | $(MSGFMT) - -o $@; \
+ fi)
+
+ #$(info $(call gb_MoTarget_get_target,$(1)))
+--- libreoffice-6.0.6.2/configure.ac
++++ libreoffice-6.0.6.2/configure.ac
+@@ -11749,18 +11749,6 @@
+ fi
+ fi
+ fi
+- if test -z "$MSGUNIQ"; then
+- if test -n "$LODE_HOME" -a -x "$LODE_HOME/opt/bin/msguniq" ; then
+- MSGUNIQ="$LODE_HOME/opt/bin/msguniq"
+- elif test -x "/opt/lo/bin/msguniq"; then
+- MSGUNIQ="/opt/lo/bin/msguniq"
+- else
+- AC_CHECK_PROGS(MSGUNIQ, [msguniq])
+- if test -z "$MSGUNIQ"; then
+- AC_MSG_ERROR([msguniq not found. Install GNU gettext, or re-run without languages.])
+- fi
+- fi
+- fi
+ fi
+ AC_SUBST(MSGFMT)
+ AC_SUBST(MSGUNIQ)