summaryrefslogtreecommitdiff
path: root/user/libsrtp
diff options
context:
space:
mode:
Diffstat (limited to 'user/libsrtp')
-rw-r--r--user/libsrtp/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/user/libsrtp/APKBUILD b/user/libsrtp/APKBUILD
new file mode 100644
index 000000000..9fb86a1ed
--- /dev/null
+++ b/user/libsrtp/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Zach van Rijn <me@zv.io>
+pkgname=libsrtp
+pkgver=2.5.0
+pkgrel=0
+pkgdesc="implementation of the Secure Real-time Transport Protocol (SRTP)"
+url="https://github.com/cisco/libsrtp"
+arch="all"
+options=""
+license="BSD-3-Clause"
+makedepends="doxygen libpcap-dev meson openssl-dev"
+subpackages="$pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/cisco/libsrtp/archive/v$pkgver.tar.gz"
+
+build() {
+ meson \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --buildtype=release \
+ -Dcrypto-library=openssl \
+ . build
+ meson compile -C build
+}
+
+check() {
+ meson test --no-rebuild --print-errorlogs -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install --no-rebuild -C build
+}
+sha512sums="bd679ab65ccf22ca30fe867b9649a0b84cfa6fad6e22eb10f081141632f6dd56479a04d525b865f11fd46007303ca211065d9c170e4820d6ea7055403702340a libsrtp-2.5.0.tar.gz"