summaryrefslogtreecommitdiff
path: root/user/libtheora/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/libtheora/APKBUILD')
-rw-r--r--user/libtheora/APKBUILD8
1 files changed, 2 insertions, 6 deletions
diff --git a/user/libtheora/APKBUILD b/user/libtheora/APKBUILD
index a1e1e1948..2dd25afa7 100644
--- a/user/libtheora/APKBUILD
+++ b/user/libtheora/APKBUILD
@@ -20,7 +20,6 @@ source="http://downloads.xiph.org/releases/theora/$pkgname-$pkgver.tar.bz2
prepare() {
default_prepare
- cd "$builddir"
sed -i 's/png_\(sizeof\)/\1/g' examples/png2theora.c
@@ -31,26 +30,23 @@ prepare() {
}
build() {
- cd "$builddir"
-
CFLAGS="${CFLAGS/-Os/-O3}" CPPFLAGS="${CPPFLAGS/-Os/-O3}" ./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--enable-shared \
--enable-static
+ # workaround parallel build issue
+ make -C lib libtheoradec.la
make -C lib
make
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
-
make -j1 DESTDIR="$pkgdir" install
install -m755 -d "$pkgdir"/usr/share/licenses/$pkgname