summaryrefslogtreecommitdiff
path: root/user/libtheora/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/libtheora/APKBUILD')
-rw-r--r--user/libtheora/APKBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/user/libtheora/APKBUILD b/user/libtheora/APKBUILD
index 2dd25afa7..618f413b9 100644
--- a/user/libtheora/APKBUILD
+++ b/user/libtheora/APKBUILD
@@ -30,7 +30,9 @@ prepare() {
}
build() {
- CFLAGS="${CFLAGS/-Os/-O3}" CPPFLAGS="${CPPFLAGS/-Os/-O3}" ./configure \
+ CFLAGS="$(printf '%s' "$CFLAGS" | sed 's/-Os/-O3/')" \
+ CPPFLAGS="$(printf '%s' "$CPPFLAGS" | sed 's/-Os/-O3/')" \
+ ./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \