summaryrefslogtreecommitdiff
path: root/user/libutempter/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/libutempter/APKBUILD')
-rw-r--r--user/libutempter/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/user/libutempter/APKBUILD b/user/libutempter/APKBUILD
new file mode 100644
index 000000000..5d4a3841c
--- /dev/null
+++ b/user/libutempter/APKBUILD
@@ -0,0 +1,30 @@
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=libutempter
+pkgver=1.1.6
+pkgrel=0
+pkgdesc="Library to record virtual terminal sessions in login files"
+url="No URL"
+arch="all"
+options="!check" # No test suite.
+license="LGPL-2.1+"
+depends=""
+makedepends="utmps-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="ftp://ftp.altlinux.org/pub/people/ldv/utempter/$pkgname-$pkgver.tar.bz2
+ port-to-utmpx.patch
+ "
+
+build() {
+ cd "$builddir"
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ # utmps allows us to log without root!
+ chmod 0755 "$pkgdir"/usr/lib/utempter/utempter
+}
+
+sha512sums="6ada410b981d157ae20b578de8ce20997ec0446ec6de6859549b080aa65976fc9900d211600dab09dc3d0d109daabad0994a648b093b8781b442ff26ca17fede libutempter-1.1.6.tar.bz2
+b2d0bc9075bda0dc3404458547ee2d190855d6d8b2c209ae70b763ea11baa0569bd3b167589ad09f77c82075430ca60ffe758a925b9fd4124b5945b93c19a10d port-to-utmpx.patch"