summaryrefslogtreecommitdiff
path: root/user/libvncserver/LibVNCServer-0.9.10-system_minilzo.patch
diff options
context:
space:
mode:
Diffstat (limited to 'user/libvncserver/LibVNCServer-0.9.10-system_minilzo.patch')
-rw-r--r--user/libvncserver/LibVNCServer-0.9.10-system_minilzo.patch67
1 files changed, 67 insertions, 0 deletions
diff --git a/user/libvncserver/LibVNCServer-0.9.10-system_minilzo.patch b/user/libvncserver/LibVNCServer-0.9.10-system_minilzo.patch
new file mode 100644
index 000000000..34e789bba
--- /dev/null
+++ b/user/libvncserver/LibVNCServer-0.9.10-system_minilzo.patch
@@ -0,0 +1,67 @@
+diff -up LibVNCServer-0.9.10/libvncclient/Makefile.am.system_minilzo LibVNCServer-0.9.10/libvncclient/Makefile.am
+--- LibVNCServer-0.9.10/libvncclient/Makefile.am.system_minilzo 2014-04-05 18:38:35.000000000 -0500
++++ LibVNCServer-0.9.10/libvncclient/Makefile.am 2014-04-29 08:56:27.861761880 -0500
+@@ -13,10 +13,10 @@ endif
+ endif
+
+
+-libvncclient_la_SOURCES=cursor.c listen.c rfbproto.c sockets.c vncviewer.c ../common/minilzo.c $(TLSSRCS)
+-libvncclient_la_LIBADD=$(TLSLIBS) $(VA_LIBS)
++libvncclient_la_SOURCES=cursor.c listen.c rfbproto.c sockets.c vncviewer.c $(TLSSRCS)
++libvncclient_la_LIBADD=$(TLSLIBS) $(VA_LIBS) -lminilzo
+
+-noinst_HEADERS=../common/lzodefs.h ../common/lzoconf.h ../common/minilzo.h tls.h
++noinst_HEADERS=tls.h
+
+ rfbproto.o: rfbproto.c corre.c hextile.c rre.c tight.c zlib.c zrle.c ultra.c
+
+diff -up LibVNCServer-0.9.10/libvncclient/rfbproto.c.system_minilzo LibVNCServer-0.9.10/libvncclient/rfbproto.c
+--- LibVNCServer-0.9.10/libvncclient/rfbproto.c.system_minilzo 2014-04-05 18:38:35.000000000 -0500
++++ LibVNCServer-0.9.10/libvncclient/rfbproto.c 2014-04-29 08:39:57.638331693 -0500
+@@ -61,7 +61,7 @@
+ #include <gcrypt.h>
+ #endif
+
+-#include "minilzo.h"
++#include <lzo/minilzo.h>
+ #include "tls.h"
+
+ /*
+diff -up LibVNCServer-0.9.10/libvncserver/Makefile.am.system_minilzo LibVNCServer-0.9.10/libvncserver/Makefile.am
+--- LibVNCServer-0.9.10/libvncserver/Makefile.am.system_minilzo 2014-04-05 18:38:35.000000000 -0500
++++ LibVNCServer-0.9.10/libvncserver/Makefile.am 2014-04-29 08:39:57.638331693 -0500
+@@ -37,7 +37,7 @@ include_HEADERS=../rfb/rfb.h ../rfb/rfbc
+
+ noinst_HEADERS=../common/d3des.h ../rfb/default8x16.h zrleoutstream.h \
+ zrlepalettehelper.h zrletypes.h private.h scale.h rfbssl.h rfbcrypto.h \
+- ../common/minilzo.h ../common/lzoconf.h ../common/lzodefs.h ../common/md5.h ../common/sha1.h \
++ ../common/md5.h ../common/sha1.h \
+ $(TIGHTVNCFILETRANSFERHDRS)
+
+ EXTRA_DIST=tableinit24.c tableinittctemplate.c tabletranstemplate.c \
+@@ -54,11 +54,11 @@ endif
+ LIB_SRCS = main.c rfbserver.c rfbregion.c auth.c sockets.c $(WEBSOCKETSSRCS) \
+ stats.c corre.c hextile.c rre.c translate.c cutpaste.c \
+ httpd.c cursor.c font.c \
+- draw.c selbox.c ../common/d3des.c ../common/vncauth.c cargs.c ../common/minilzo.c ultra.c scale.c \
++ draw.c selbox.c ../common/d3des.c ../common/vncauth.c cargs.c ultra.c scale.c \
+ $(ZLIBSRCS) $(TIGHTSRCS) $(TIGHTVNCFILETRANSFERSRCS)
+
+ libvncserver_la_SOURCES=$(LIB_SRCS)
+-libvncserver_la_LIBADD=$(WEBSOCKETSSSLLIBS)
++libvncserver_la_LIBADD=$(WEBSOCKETSSSLLIBS) -lminilzo
+
+ lib_LTLIBRARIES=libvncserver.la
+
+diff -up LibVNCServer-0.9.10/libvncserver/ultra.c.system_minilzo LibVNCServer-0.9.10/libvncserver/ultra.c
+--- LibVNCServer-0.9.10/libvncserver/ultra.c.system_minilzo 2014-04-05 18:38:35.000000000 -0500
++++ LibVNCServer-0.9.10/libvncserver/ultra.c 2014-04-29 08:39:57.638331693 -0500
+@@ -8,7 +8,7 @@
+ */
+
+ #include <rfb/rfb.h>
+-#include "minilzo.h"
++#include <lzo/minilzo.h>
+
+ /*
+ * cl->beforeEncBuf contains pixel data in the client's format.