summaryrefslogtreecommitdiff
path: root/user/libvorbis/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/libvorbis/APKBUILD')
-rw-r--r--user/libvorbis/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/user/libvorbis/APKBUILD b/user/libvorbis/APKBUILD
new file mode 100644
index 000000000..2b5b41f4c
--- /dev/null
+++ b/user/libvorbis/APKBUILD
@@ -0,0 +1,41 @@
+# Maintainer:
+pkgname=libvorbis
+pkgver=1.3.6
+pkgrel=0
+pkgdesc="Vorbis audio codec library"
+url="https://xiph.org/vorbis/"
+arch="all"
+options="!check" # Test suite doesn't compile.
+license="BSD-3-Clause"
+subpackages="$pkgname-dev $pkgname-doc"
+makedepends="libogg-dev"
+source="https://downloads.xiph.org/releases/vorbis/$pkgname-$pkgver.tar.xz
+ CVE-2017-14160.patch
+ "
+
+# secfixes:
+# 1.3.5-r4:
+# - CVE-2017-14632
+# - CVE-2017-14633
+# 1.3.5-r3:
+# - CVE-2017-14160
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="a5d990bb88db2501b16f8eaee9f2ecb599cefd7dab2134d16538d8905263a972157c7671867848c2a8a358bf5e5dbc7721205ece001032482f168be7bda4f132 libvorbis-1.3.6.tar.xz
+4c2f7be947f2159ae47175cba89950c7b7d357b37a20d54382e4fbecd8c268b148e6cb86cb148945c7b68bbe8b14f466e910b35b80903ab51f1b02cfccf5806e CVE-2017-14160.patch"