summaryrefslogtreecommitdiff
path: root/user/libxcb/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/libxcb/APKBUILD')
-rw-r--r--user/libxcb/APKBUILD14
1 files changed, 5 insertions, 9 deletions
diff --git a/user/libxcb/APKBUILD b/user/libxcb/APKBUILD
index 53db51310..cac678bff 100644
--- a/user/libxcb/APKBUILD
+++ b/user/libxcb/APKBUILD
@@ -1,20 +1,19 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=libxcb
-pkgver=1.13.1
+pkgver=1.14
pkgrel=0
pkgdesc="X11 C language Binding"
url="https://xcb.freedesktop.org/"
arch="all"
license="X11"
depends=""
-subpackages="$pkgname-dev $pkgname-doc"
depends_dev="libxau-dev xcb-proto"
checkdepends="check-dev"
-makedepends="$depends_dev libxslt python3 libpthread-stubs libxdmcp-dev"
-source="https://xcb.freedesktop.org/dist/$pkgname-$pkgver.tar.bz2"
+subpackages="$pkgname-dev $pkgname-doc"
+makedepends="$depends_dev libxslt python3 libxdmcp-dev"
+source="https://www.X.org/releases/individual/lib/libxcb-$pkgver.tar.xz"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -27,14 +26,11 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
- install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
-sha512sums="763edff9572623674f75a858adc57b5c09591f508cc5d5093218e7bb047abdbe0a0108bd465419a8bf15c7dcdc85efdd2d4d9fd56605c41475d15dc992640c23 libxcb-1.13.1.tar.bz2"
+sha512sums="b90a23204b0d2c29d8b115577edb01df0465e02d6a8876550fecd62375d24a5d5f872ddd5946772ddba077cadce75b12c7a6d218469dc30b5b92bc82188e8bc6 libxcb-1.14.tar.xz"