summaryrefslogtreecommitdiff
path: root/user/libxcb/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/libxcb/APKBUILD')
-rw-r--r--user/libxcb/APKBUILD14
1 files changed, 6 insertions, 8 deletions
diff --git a/user/libxcb/APKBUILD b/user/libxcb/APKBUILD
index 53db51310..ddeb95531 100644
--- a/user/libxcb/APKBUILD
+++ b/user/libxcb/APKBUILD
@@ -1,20 +1,20 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=libxcb
pkgver=1.13.1
-pkgrel=0
+pkgrel=1
pkgdesc="X11 C language Binding"
url="https://xcb.freedesktop.org/"
arch="all"
license="X11"
depends=""
-subpackages="$pkgname-dev $pkgname-doc"
depends_dev="libxau-dev xcb-proto"
checkdepends="check-dev"
+subpackages="$pkgname-dev $pkgname-doc"
makedepends="$depends_dev libxslt python3 libpthread-stubs libxdmcp-dev"
-source="https://xcb.freedesktop.org/dist/$pkgname-$pkgver.tar.bz2"
+source="https://xcb.freedesktop.org/dist/$pkgname-$pkgver.tar.bz2
+ 0001-tests-Support-Check-0.13.0-API.patch"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -27,14 +27,12 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
- install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
-sha512sums="763edff9572623674f75a858adc57b5c09591f508cc5d5093218e7bb047abdbe0a0108bd465419a8bf15c7dcdc85efdd2d4d9fd56605c41475d15dc992640c23 libxcb-1.13.1.tar.bz2"
+sha512sums="763edff9572623674f75a858adc57b5c09591f508cc5d5093218e7bb047abdbe0a0108bd465419a8bf15c7dcdc85efdd2d4d9fd56605c41475d15dc992640c23 libxcb-1.13.1.tar.bz2
+c5731fc76566f9f27d6d6f762971e07d2c27ed34a4881b8fa03c332f2d6a163954efb658682043e181170b93d3c979fa2c2374d3b25c80eead5747dea684037a 0001-tests-Support-Check-0.13.0-API.patch"