summaryrefslogtreecommitdiff
path: root/user/lmdb/lmdb_make.patch
diff options
context:
space:
mode:
Diffstat (limited to 'user/lmdb/lmdb_make.patch')
-rw-r--r--user/lmdb/lmdb_make.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/user/lmdb/lmdb_make.patch b/user/lmdb/lmdb_make.patch
new file mode 100644
index 000000000..deb49ee76
--- /dev/null
+++ b/user/lmdb/lmdb_make.patch
@@ -0,0 +1,18 @@
+diff --git a/Makefile b/Makefile
+index 0940c49..7a47dc2 100644
+--- a/Makefile
++++ b/Makefile
+@@ -23,11 +23,11 @@ AR = ar
+ W = -W -Wall -Wno-unused-parameter -Wbad-function-cast -Wuninitialized
+ THREADS = -pthread
+ OPT = -O2 -g
+-CFLAGS = $(THREADS) $(OPT) $(W) $(XCFLAGS)
++CFLAGS = $(THREADS) $(OPT) $(W) $(XCFLAGS) -fPIC
+ LDLIBS =
+ SOLIBS =
+ SOEXT = .so
+-prefix = /usr/local
++prefix = /usr
+ exec_prefix = $(prefix)
+ bindir = $(exec_prefix)/bin
+ libdir = $(exec_prefix)/lib