summaryrefslogtreecommitdiff
path: root/user/lua-lgi/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/lua-lgi/APKBUILD')
-rw-r--r--user/lua-lgi/APKBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/user/lua-lgi/APKBUILD b/user/lua-lgi/APKBUILD
index 857fa26be..f9b07ca3b 100644
--- a/user/lua-lgi/APKBUILD
+++ b/user/lua-lgi/APKBUILD
@@ -9,24 +9,25 @@ arch="all"
license="MIT"
options="!check" # checks require dbus
depends=""
-makedepends="glib-dev gobject-introspection-dev libffi-dev"
+makedepends="glib-dev gobject-introspection-dev libffi-dev lua5.3-dev"
subpackages="$pkgname-doc"
source="lgi-$pkgver.tar.gz::https://github.com/pavouk/lgi/archive/$pkgver.tar.gz"
-
builddir="$srcdir"/lgi-$pkgver
+
build() {
cd "$builddir"
- make PREFIX=/usr LUA_CFLAGS="$(pkg-config --cflags lua)"
+ make PREFIX=/usr LUA_VERSION="5.3" \
+ LUA_CFLAGS="$(pkg-config --cflags lua)"
}
check() {
- cd "$builddir"
- make -C "$srcdir"/build-$_i check
+ cd "$builddir"
+ make check
}
package() {
cd "$builddir"
- make install PREFIX=/usr DESTDIR="$pkgdir"
+ make install PREFIX=/usr LUA_VERSION="5.3" DESTDIR="$pkgdir"
mkdir -p "$pkgdir"/usr/share/doc/lua-lgi
cp -r docs/* samples "$pkgdir"/usr/share/doc/lua-lgi/