summaryrefslogtreecommitdiff
path: root/user/lxqt-powermanagement/revert-kwindowsystem-bump.patch
diff options
context:
space:
mode:
Diffstat (limited to 'user/lxqt-powermanagement/revert-kwindowsystem-bump.patch')
-rw-r--r--user/lxqt-powermanagement/revert-kwindowsystem-bump.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/user/lxqt-powermanagement/revert-kwindowsystem-bump.patch b/user/lxqt-powermanagement/revert-kwindowsystem-bump.patch
new file mode 100644
index 000000000..b7bc62975
--- /dev/null
+++ b/user/lxqt-powermanagement/revert-kwindowsystem-bump.patch
@@ -0,0 +1,32 @@
+diff '--color=auto' -Nurd lxqt-powermanagement-1.4.0/CMakeLists.txt lxqt-powermanagement-1.4.0.new/CMakeLists.txt
+--- lxqt-powermanagement-1.4.0/CMakeLists.txt 2023-11-05 03:52:24.000000000 -0800
++++ lxqt-powermanagement-1.4.0.new/CMakeLists.txt 2023-11-26 05:38:24.944824050 -0800
+@@ -16,7 +16,7 @@
+ option(UPDATE_TRANSLATIONS "Update source translation translations/*.ts files" OFF)
+
+ set(LXQTBT_MINIMUM_VERSION "0.13.0")
+-set(KF5_MINIMUM_VERSION "5.101.0")
++set(KF5_MINIMUM_VERSION "5.36.0")
+ set(LXQT_MINIMUM_VERSION "1.4.0")
+ set(QT_MINIMUM_VERSION "5.15.0")
+
+diff '--color=auto' -Nurd lxqt-powermanagement-1.4.0/src/idlenesswatcher.cpp lxqt-powermanagement-1.4.0.new/src/idlenesswatcher.cpp
+--- lxqt-powermanagement-1.4.0/src/idlenesswatcher.cpp 2023-11-05 03:52:24.000000000 -0800
++++ lxqt-powermanagement-1.4.0.new/src/idlenesswatcher.cpp 2023-11-26 05:38:48.084639516 -0800
+@@ -30,7 +30,6 @@
+ #include <Solid/Device>
+ #include <Solid/Battery>
+ #include <KWindowSystem/KWindowSystem>
+-#include <KWindowSystem/KX11Extras>
+ #include <KWindowSystem/KWindowInfo>
+ #include <QDebug>
+ #include <LXQt/lxqtnotification.h>
+@@ -162,7 +161,7 @@
+
+ // check if disable Idleness when fullscreen is enabled
+ if (mPSettings.isDisableIdlenessWhenFullscreenEnabled()) {
+- WId w = KX11Extras::activeWindow();
++ WId w = KWindowSystem::activeWindow();
+ KWindowInfo info(w, NET::WMState);
+ if (info.hasState(NET::FullScreen)) {
+ QTimer::singleShot(0, this, [] {