summaryrefslogtreecommitdiff
path: root/user/mosh/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/mosh/APKBUILD')
-rw-r--r--user/mosh/APKBUILD78
1 files changed, 78 insertions, 0 deletions
diff --git a/user/mosh/APKBUILD b/user/mosh/APKBUILD
new file mode 100644
index 000000000..323891e69
--- /dev/null
+++ b/user/mosh/APKBUILD
@@ -0,0 +1,78 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Dan Theisen <djt@hxx.in>
+pkgname=mosh
+pkgver=1.3.2
+pkgrel=0
+pkgdesc="Mobile shell surviving disconnects with local echo and line editing"
+url="https://mosh.org"
+arch="all"
+license="GPL-3.0+"
+depends="$pkgname-client $pkgname-server"
+checkdepends="tmux perl"
+makedepends="ncurses-dev zlib-dev openssl-dev perl-dev perl-io-tty
+ protobuf-dev automake autoconf libtool gzip"
+subpackages="$pkgname-doc $pkgname-client $pkgname-server
+ $pkgname-bash-completion:bashcomp:noarch"
+source="https://mosh.org/$pkgname-$pkgver.tar.gz
+ fix-ppc64le-build-with-musl.patch"
+
+prepare() {
+ default_prepare
+ # Test unicode-later-combining is failing. Ideally we want to fix it.
+ sed -i '/unicode-later-combining.test/d' "$builddir"/src/tests/Makefile.am
+ cd "$builddir"
+ ./autogen.sh
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --enable-examples
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check VERBOSE=1 V=1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+bashcomp() {
+ depends=""
+ pkgdesc="Bash completions for $pkgname"
+ install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
+
+ install -Dm644 "$builddir"/conf/bash-completion/completions/mosh \
+ "$subpkgdir"/usr/share/bash-completion/completions/$pkgname
+}
+
+server() {
+ replaces="mosh"
+ pkgdesc="Mosh server"
+ depends=""
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/mosh-server \
+ "$subpkgdir"/usr/bin/
+}
+
+client() {
+ replaces="mosh"
+ pkgdesc="Mosh client"
+ depends="openssh-client perl-io-tty"
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/mosh-client \
+ "$subpkgdir"/usr/bin/
+}
+
+sha512sums="f400e8fe7ba2ab7362311fc12a00ec69587505f901988aeee500fc68d38a388218500a3f602111c883ff23a9d43572114fcf0a8bf505df203691e5b597615769 mosh-1.3.2.tar.gz
+a276dde98a2dab63ad9c9c05468c55983a95f482878c5694713810b561eae1ea5618efc72431a17ee5b5014b12ee9709c6a8cbf582620294e7888cc837cd073c fix-ppc64le-build-with-musl.patch"