summaryrefslogtreecommitdiff
path: root/user/mosquitto/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/mosquitto/APKBUILD')
-rw-r--r--user/mosquitto/APKBUILD24
1 files changed, 8 insertions, 16 deletions
diff --git a/user/mosquitto/APKBUILD b/user/mosquitto/APKBUILD
index 46460cd92..3848992b8 100644
--- a/user/mosquitto/APKBUILD
+++ b/user/mosquitto/APKBUILD
@@ -17,6 +17,7 @@ install="$pkgname.pre-install"
source="http://mosquitto.org/files/source/$pkgname-$pkgver.tar.gz
mosquitto.initd
openrc-conf.patch
+ endian.patch
"
# secfixes:
@@ -46,8 +47,12 @@ build() {
check() {
# Explicitly disable tests, instead of enabling only good ones.
+ # 08-ssl-connect-cert-auth-without-py: #687
+ # Other two: https://github.com/eclipse/mosquitto/issues/2550
sed -i test/broker/test.py \
- -e '/08-ssl-connect-cert-auth-without.py/d' `#687` \
+ -e '/08-ssl-connect-cert-auth-without.py/d' \
+ -e '/06-bridge-b2br-late-connection-retain.py/d' \
+ -e '/11-pub-props.py/d' \
;
sed -i test/lib/test.py \
-e '/02-subscribe-qos1.py/d' \
@@ -55,20 +60,6 @@ check() {
sed -i test/client/Makefile \
-e '/test.sh/d' \
;
- # These seem to ppc64 (or BE) related.
- sed -i test/unit/persist_read_test.c \
- -e '/CU_add_test.*TEST_v3_config_ok/d' \
- -e '/CU_add_test.*TEST_v3_bad_chunk/d' \
- -e '/CU_add_test.*TEST_v3_message_store/d' \
- -e '/CU_add_test.*TEST_v3_retain/d' \
- -e '/CU_add_test.*TEST_v4_config_ok/d' \
- -e '/CU_add_test.*TEST_v4_message_store/d' \
- -e '/CU_add_test.*TEST_v5_bad_chunk/d' \
- -e '/CU_add_test.*TEST_v6_config_ok/d' \
- -e '/CU_add_test.*TEST_v6_message_store/d' \
- -e '/CU_add_test.*TEST_v6_message_store_props/d' \
- -e '/CU_add_test.*TEST_v6_retain/d' \
- ;
make ptest
}
@@ -96,4 +87,5 @@ clients() {
sha512sums="a9e4f41b9af679b30318570e86a465546024651373df10e3b132f4593b89d22d0dbac01bb7371a57132ba030a2e73971c612acb5c9ac12f5ccd06aa38d9444c2 mosquitto-2.0.14.tar.gz
681fddc737b3ef3e6c052f0c854a730df290352640a18a63e23ef83d14c425558aff87805d1eb95e44de101b5df48872173af9f5414464ffa8cf727ea2c0491e mosquitto.initd
-b07f9bec2751ab32c43f53e74d8fca18dbf2d7ce7f8fab562dbcf75de19609ba6219d735ac504697404e0ed36613a14074e3a19e735297195877798f778d337a openrc-conf.patch"
+b07f9bec2751ab32c43f53e74d8fca18dbf2d7ce7f8fab562dbcf75de19609ba6219d735ac504697404e0ed36613a14074e3a19e735297195877798f778d337a openrc-conf.patch
+89f738f77732500bc2aff3086b891c1e537510e756baf0ac92c1462c2ef7e47cdc62536d90174e6b6c80637199e463609723f9915999c0b95ce878ebbed739a1 endian.patch"