summaryrefslogtreecommitdiff
path: root/user/mosquitto
diff options
context:
space:
mode:
Diffstat (limited to 'user/mosquitto')
-rw-r--r--user/mosquitto/APKBUILD7
-rw-r--r--user/mosquitto/disable-flaky-test.patch14
2 files changed, 17 insertions, 4 deletions
diff --git a/user/mosquitto/APKBUILD b/user/mosquitto/APKBUILD
index 67ec942a1..71e1fb99c 100644
--- a/user/mosquitto/APKBUILD
+++ b/user/mosquitto/APKBUILD
@@ -2,12 +2,11 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=mosquitto
-pkgver=1.6.9
+pkgver=1.6.10
pkgrel=0
pkgdesc="An Open Source MQTT Broker"
url="https://mosquitto.org/"
arch="all"
-options="!check" # "Connection refused" during testing.
license="EPL-1.0 AND EDL-1.0 AND MIT AND BSD-3-Clause"
depends=""
checkdepends="python3"
@@ -74,7 +73,7 @@ clients() {
mv "$pkgdir"/usr/bin/mosquitto_[ps]ub "$subpkgdir"/usr/bin/
}
-sha512sums="f78228a1e8305e4d89b34250981ed2c5fe5317636003636dc90f6fa2b1e3ca3c8fadb705ee7301f5252456cb093a6547bd46a255ca3d9fb5cdced697738d6eb7 mosquitto-1.6.9.tar.gz
+sha512sums="2050a7a7af864057a177728f1cab9f6db70d6d1ea609d90c637723c2c9cfc9716429739302abd6742bde932716fae340854fff35956693dfee4ef31ce7b04a25 mosquitto-1.6.10.tar.gz
681fddc737b3ef3e6c052f0c854a730df290352640a18a63e23ef83d14c425558aff87805d1eb95e44de101b5df48872173af9f5414464ffa8cf727ea2c0491e mosquitto.initd
-3886171e36f759a717aa6626d5b8dbd392963c737d5de28b4d52b81359008927b99ff7a0ca82f56a0e5deaed4585571759ba9216336a664fd346845837c2bc18 disable-flaky-test.patch
+daaae48d49e49a9911f152dfc80f67f2371ad62647d3324b360eb83f816c0898469c135209ddb69e80a29b313bbe3b6ee11463955c97a44584921c13832a07be disable-flaky-test.patch
b07f9bec2751ab32c43f53e74d8fca18dbf2d7ce7f8fab562dbcf75de19609ba6219d735ac504697404e0ed36613a14074e3a19e735297195877798f778d337a openrc-conf.patch"
diff --git a/user/mosquitto/disable-flaky-test.patch b/user/mosquitto/disable-flaky-test.patch
index 8fd51c403..1dade3cd4 100644
--- a/user/mosquitto/disable-flaky-test.patch
+++ b/user/mosquitto/disable-flaky-test.patch
@@ -9,3 +9,17 @@
./11-persistent-subscription.py
./11-persistent-subscription-v5.py
./11-persistent-subscription-no-local.py
+
+Upstream issue: https://github.com/eclipse/mosquitto/issues/1659
+
+--- mosquitto-1.6.10/test/lib/Makefile 2020-05-25 22:49:59.000000000 +0000
++++ mosquitto-1.6.10/test/lib/Makefile 2020-06-20 01:41:00.350012338 +0000
+@@ -33,7 +33,7 @@ c : test-compile
+ ./02-subscribe-qos0.py $@/02-subscribe-qos0.test
+ ./02-subscribe-qos1.py $@/02-subscribe-qos1.test
+ ./02-subscribe-qos1.py $@/02-subscribe-qos1-async1.test
+- ./02-subscribe-qos1.py $@/02-subscribe-qos1-async2.test
++ #./02-subscribe-qos1.py $@/02-subscribe-qos1-async2.test
+ ./02-subscribe-qos2.py $@/02-subscribe-qos2.test
+ ./02-unsubscribe-multiple-v5.py $@/02-unsubscribe-multiple-v5.test
+ ./02-unsubscribe-v5.py $@/02-unsubscribe-v5.test