summaryrefslogtreecommitdiff
path: root/user/musl-locales/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/musl-locales/APKBUILD')
-rw-r--r--user/musl-locales/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/user/musl-locales/APKBUILD b/user/musl-locales/APKBUILD
new file mode 100644
index 000000000..9bbf0c49b
--- /dev/null
+++ b/user/musl-locales/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Alyx <alyx@leuhta.com>
+# Maintainer: Alyx <alyx@leuhta.com>
+pkgname=musl-locales
+pkgver=0.20190626
+pkgrel=0
+pkgdesc="Locale program for musl"
+url="https://gitlab.com/rilian-la-te/musl-locales"
+arch="all"
+options="!check" # No test suite.
+license="MIT"
+depends=""
+makedepends="cmake make gettext-tiny-dev"
+subpackages="$pkgname-lang"
+source="https://distfiles.adelielinux.org/source/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname"
+
+build() {
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ .
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="f65381b6eec64e69e649dacd3a3f75e74d9236164a1277bd2493afb3cb469049bee026d590a7207413b4d92675f877d1d8d3b16c58840a6e15a81638a2f731f2 musl-locales-0.20190626.tar.gz"