summaryrefslogtreecommitdiff
path: root/user/nghttp2
diff options
context:
space:
mode:
Diffstat (limited to 'user/nghttp2')
-rw-r--r--user/nghttp2/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/user/nghttp2/APKBUILD b/user/nghttp2/APKBUILD
new file mode 100644
index 000000000..f3c0b14f9
--- /dev/null
+++ b/user/nghttp2/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer:
+pkgname=nghttp2
+pkgver=1.32.0
+pkgrel=0
+pkgdesc="Experimental HTTP/2 client, server and proxy"
+url="https://nghttp2.org/"
+arch="all"
+license="MIT"
+makedepends="c-ares-dev libev-dev libxml2-dev openssl-dev zlib-dev"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
+source="https://github.com/tatsuhiro-t/$pkgname/releases/download/v$pkgver/nghttp2-$pkgver.tar.xz"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --disable-static \
+ --without-neverbleed \
+ --without-jemalloc \
+ --disable-python-bindings \
+ --enable-app
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="ec7e417fbc5497861d2b6dde5145da1640b36441882824e85940e5ca6ac52ec444aa7123846960f7211dd96462eab421d39f9cc49454f3f52e0dcdb36402044e nghttp2-1.32.0.tar.xz"