summaryrefslogtreecommitdiff
path: root/user/nmap
diff options
context:
space:
mode:
Diffstat (limited to 'user/nmap')
-rw-r--r--user/nmap/APKBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/user/nmap/APKBUILD b/user/nmap/APKBUILD
index 3b256aaa3..304c94cae 100644
--- a/user/nmap/APKBUILD
+++ b/user/nmap/APKBUILD
@@ -7,7 +7,8 @@ url="https://nmap.org/"
arch="all"
license="GPL-2.0-only"
depends=""
-makedepends="linux-headers openssl-dev libpcap-dev pcre-dev zlib-dev libssh2-dev lua5.3-dev"
+makedepends="linux-headers openssl-dev libpcap-dev pcre-dev zlib-dev
+ libssh2-dev lua5.3-dev"
subpackages="
$pkgname-doc
$pkgname-scripts::noarch
@@ -33,7 +34,7 @@ build() {
export CFLAGS=-g3
export CPPFLAGS=-g3
export CXXFLAGS=-g3
- ./configure \
+ LDFLAGS="$LDFLAGS -L/usr/lib/lua5.3" ./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
@@ -47,7 +48,7 @@ build() {
--with-libpcre=yes \
--with-libz=yes \
--with-libssh2=yes \
- --with-liblua=/usr/lua5.3
+ --with-liblua=yes
make
}