summaryrefslogtreecommitdiff
path: root/user/node
diff options
context:
space:
mode:
Diffstat (limited to 'user/node')
-rw-r--r--user/node/APKBUILD14
-rw-r--r--user/node/env-nullptr-backport.patch28
-rw-r--r--user/node/flaky-sigint-test.patch73
-rw-r--r--user/node/flaky-tests.patch12
-rw-r--r--user/node/pmmx-time64.patch12
5 files changed, 30 insertions, 109 deletions
diff --git a/user/node/APKBUILD b/user/node/APKBUILD
index 6c5e1e398..6cd046b61 100644
--- a/user/node/APKBUILD
+++ b/user/node/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=node
-pkgver=18.12.1
-pkgrel=1
+pkgver=18.15.0
+pkgrel=0
pkgdesc="JavaScript runtime"
url="https://nodejs.org/"
arch="all !ppc" # #837
@@ -13,10 +13,9 @@ makedepends="c-ares-dev http-parser-dev icu-dev libexecinfo-dev libuv-dev
nghttp2-dev openssl-dev python3 zlib-dev samurai"
subpackages="$pkgname-dev $pkgname-doc"
source="https://nodejs.org/download/release/v$pkgver/node-v$pkgver.tar.xz
- env-nullptr-backport.patch
- flaky-sigint-test.patch
pmmx-test.patch
pmmx-time64.patch
+ flaky-tests.patch
"
builddir="$srcdir/$pkgname-v$pkgver"
@@ -66,8 +65,7 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="1eb4978a1de19c026561a8484df87bdeb6f7f2ec8ae1eb38b6241d0b0ff6158a4a7d19f42df7e295a63b8047eaf862a7470494143b2e27bb36b65e4663966588 node-v18.12.1.tar.xz
-e8374b4838256a0762b8c5448dd84fb5ac80aec0df5bb0869941288897a5084f74631e37619f0814c7fe98762e7f603a13511d68594e4f6c46ae1dd420bb61ad env-nullptr-backport.patch
-9d6451871cfb4940ed5c53ae95f37761480890e2ed50cf7029f070f23b343721763b0339f77da3c61a878d65f7b2dd9a91012e62fc61e775a10a0f1d2a8ebe80 flaky-sigint-test.patch
+sha512sums="e41fcda469809186fd724ef4691e25f4a5bd81357ee99acf3d7faa1190a69c19cb62bd14aea199ca6f8b5cf9687af7d898cdf605ea2414d2c04db87ddb3b4dc8 node-v18.15.0.tar.xz
277e226f3906f791bae6aedd0b74b0e2c52b6154eb2dc0c568417ad94a0722078e4fbbbe15c59d4ba0b59cdb4ad45b5e9620f14d75694a15531857cd29aa044a pmmx-test.patch
-c4ce3c583d3c8d5601701bf60f5ae9be5dec9b7722c67182b717d714b4ddb246d77d6be84437e5038bff998072b3e7e1f9cfe138230590f3d674620273937ddc pmmx-time64.patch"
+bf78e52c60b4567854eaa9d9433ade8a318a356cb326dded99e800df35a9f475390a0cf8b0c8e595bbdb3702838eafe91801cd646576aa7fa7966b37d794e380 pmmx-time64.patch
+1df6974e6f4acca31a553426437233c2736a5b509e0d31b00d13d83d644800bf0703c61fe05df4dff9fe07a08cd6997b38177fb264e09eae58464623a548ff7d flaky-tests.patch"
diff --git a/user/node/env-nullptr-backport.patch b/user/node/env-nullptr-backport.patch
deleted file mode 100644
index 02878dc25..000000000
--- a/user/node/env-nullptr-backport.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From 8214cc175f0c4e600a3af5cedd94e4fd4d8d839e Mon Sep 17 00:00:00 2001
-From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
-Date: Sat, 17 Dec 2022 19:39:01 -0600
-Subject: [PATCH] env: check size of args before using for exec_path
-
-If we are in an artifically created Environment that has no args set,
-and uv_exepath returns an error (for instance, if /proc is not mounted
-on a Linux system), then we crash with a nullptr deref attempting to
-use argv[0].
-
-Fixes: https://github.com/nodejs/node/issues/45901
----
- src/env.cc | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/env.cc b/src/env.cc
-index 5172d71ad6a6..97e0ac581113 100644
---- node-v16.15.0/src/env.cc.old 2022-04-26 22:03:30.000000000 +0000
-+++ node-v16.15.0/src/env.cc 2022-12-18 01:19:23.417720353 +0000
-@@ -309,7 +309,7 @@
- std::string exec_path;
- if (uv_exepath(exec_path_buf, &exec_path_len) == 0) {
- exec_path = std::string(exec_path_buf, exec_path_len);
-- } else {
-+ } else if (argv.size() > 0) {
- exec_path = argv[0];
- }
-
diff --git a/user/node/flaky-sigint-test.patch b/user/node/flaky-sigint-test.patch
deleted file mode 100644
index 0ac7a49b1..000000000
--- a/user/node/flaky-sigint-test.patch
+++ /dev/null
@@ -1,73 +0,0 @@
-From 80ade7f46f3cd6b969153dbfc34c451fc624bdc6 Mon Sep 17 00:00:00 2001
-From: Rich Trott <rtrott@gmail.com>
-Date: Sun, 6 Nov 2022 22:41:28 -0800
-Subject: [PATCH 1/2] test: fix flaky test-repl-sigint-nested-eval
-
-There is a race condition where process.kill can be sent before the
-target is ready to receive the signal.
-
-Fixes: https://github.com/nodejs/node/issues/41123
----
- test/parallel/test-repl-sigint-nested-eval.js | 12 +++++++-----
- 1 files changed, 7 insertions(+), 5 deletions(-)
-
-diff --git a/test/parallel/test-repl-sigint-nested-eval.js b/test/parallel/test-repl-sigint-nested-eval.js
-index 28e4d44b235c..5830e08629b9 100644
---- a/test/parallel/test-repl-sigint-nested-eval.js
-+++ b/test/parallel/test-repl-sigint-nested-eval.js
-@@ -12,7 +12,7 @@ const spawn = require('child_process').spawn;
-
- process.env.REPL_TEST_PPID = process.pid;
- const child = spawn(process.execPath, [ '-i' ], {
-- stdio: [null, null, 2]
-+ stdio: [null, null, 2, 'ipc']
- });
-
- let stdout = '';
-@@ -22,7 +22,8 @@ child.stdout.on('data', function(c) {
- });
-
- child.stdout.once('data', common.mustCall(() => {
-- process.on('SIGUSR2', common.mustCall(() => {
-+ child.on('message', common.mustCall((msg) => {
-+ assert.strictEqual(msg, 'repl is busy');
- process.kill(child.pid, 'SIGINT');
- child.stdout.once('data', common.mustCall(() => {
- // Make sure REPL still works.
-@@ -30,9 +31,10 @@ child.stdout.once('data', common.mustCall(() => {
- }));
- }));
-
-- child.stdin.write('process.kill(+process.env.REPL_TEST_PPID, "SIGUSR2");' +
-- 'vm.runInThisContext("while(true){}", ' +
-- '{ breakOnSigint: true });\n');
-+ child.stdin.write(
-+ 'vm.runInThisContext("process.send(\'repl is busy\'); while(true){}", ' +
-+ '{ breakOnSigint: true });\n'
-+ );
- }));
-
- child.on('close', function(code) {
-
-From 2d9cf095d12420ef825e9ba83deb46426561ddbb Mon Sep 17 00:00:00 2001
-From: Rich Trott <rtrott@gmail.com>
-Date: Thu, 10 Nov 2022 09:00:55 -0800
-Subject: [PATCH 2/2] Update test/parallel/test-repl-sigint-nested-eval.js
-
-Co-authored-by: Antoine du Hamel <duhamelantoine1995@gmail.com>
----
- test/parallel/test-repl-sigint-nested-eval.js | 1 -
- 1 file changed, 1 deletion(-)
-
-diff --git a/test/parallel/test-repl-sigint-nested-eval.js b/test/parallel/test-repl-sigint-nested-eval.js
-index 5830e08629b9..62eb46e0af67 100644
---- a/test/parallel/test-repl-sigint-nested-eval.js
-+++ b/test/parallel/test-repl-sigint-nested-eval.js
-@@ -10,7 +10,6 @@ if (!common.isMainThread)
- const assert = require('assert');
- const spawn = require('child_process').spawn;
-
--process.env.REPL_TEST_PPID = process.pid;
- const child = spawn(process.execPath, [ '-i' ], {
- stdio: [null, null, 2, 'ipc']
- });
diff --git a/user/node/flaky-tests.patch b/user/node/flaky-tests.patch
new file mode 100644
index 000000000..d6e324d14
--- /dev/null
+++ b/user/node/flaky-tests.patch
@@ -0,0 +1,12 @@
+diff -ur a/test/parallel/parallel.status b/test/parallel/parallel.status
+--- a/test/parallel/parallel.status 2023-03-21 14:29:32.852950139 +0000
++++ b/test/parallel/parallel.status 2023-03-21 14:31:20.736931283 +0000
+@@ -17,6 +17,8 @@
+ [$system==linux]
+ # https://github.com/nodejs/node/issues/39368
+ test-domain-error-types: PASS,FLAKY
++test-net-socket-connect-without-cb: SKIP
++test-tcp-wrap-listen: SKIP
+
+ [$system==macos]
+ # https://github.com/nodejs/node/issues/42741
diff --git a/user/node/pmmx-time64.patch b/user/node/pmmx-time64.patch
index 4e92cd78c..b47a1a6fe 100644
--- a/user/node/pmmx-time64.patch
+++ b/user/node/pmmx-time64.patch
@@ -202,3 +202,15 @@
- await runTest(40691, 355, 1); // Precision loss on 32bit
- await runTest(1713037251360, 1713037251360, 1); // Precision loss
-}
+diff -ur a/src/node_file.h b/src/node_file.h
+--- a/src/node_file.h 2023-03-20 21:33:20.806694666 +0000
++++ b/src/node_file.h 2023-03-20 21:34:14.388701175 +0000
+@@ -62,7 +62,7 @@
+ AliasedBigUint64Array stats_field_bigint_array;
+
+ AliasedFloat64Array statfs_field_array;
+- AliasedBigInt64Array statfs_field_bigint_array;
++ AliasedBigUint64Array statfs_field_bigint_array;
+
+ std::vector<BaseObjectPtr<FileHandleReadWrap>>
+ file_handle_read_wrap_freelist;