summaryrefslogtreecommitdiff
path: root/user/ol/require-explicit-cdefs.patch
diff options
context:
space:
mode:
Diffstat (limited to 'user/ol/require-explicit-cdefs.patch')
-rw-r--r--user/ol/require-explicit-cdefs.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/user/ol/require-explicit-cdefs.patch b/user/ol/require-explicit-cdefs.patch
new file mode 100644
index 000000000..fd4a70ad0
--- /dev/null
+++ b/user/ol/require-explicit-cdefs.patch
@@ -0,0 +1,28 @@
+diff -ur a/tests/Makefile b/tests/Makefile
+--- a/tests/Makefile 2024-11-25 18:28:34.957193217 +0000
++++ b/tests/Makefile 2024-11-25 18:30:17.261515826 +0000
+@@ -53,20 +53,11 @@
+
+ # special case, test 64- and 32-bit both
+ # (maximal testings under main development platform)
+-ifeq ($(UNAME)-$(MACHINE),Linux-x86_64)
+-HAS_64CDEFS ?= $(call exists,-m64,sys/cdefs.h,exit)
+-ifeq ($(HAS_64CDEFS),1)
+-DEV_MACHINE ?= 1
++ifndef HAS_32CDEFS
++$(error HAS_32CDEFS is not set)
+ endif
+-# sudo apt-get install gcc-multilib
+-HAS_32CDEFS ?= $(call exists,-m32,sys/cdefs.h,exit)
+-ifeq ($(HAS_32CDEFS),1)
+-DEV_MACHINE ?= 1
+-endif
+-else
+-DEV_MACHINE ?= 0
+-HAS_64CDEFS ?= 0
+-HAS_32CDEFS ?= 0
++ifndef HAS_64CDEFS
++$(error HAS_64CDEFS is not set)
+ endif
+
+ # -------------