summaryrefslogtreecommitdiff
path: root/user/opengfx/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/opengfx/APKBUILD')
-rw-r--r--user/opengfx/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/user/opengfx/APKBUILD b/user/opengfx/APKBUILD
new file mode 100644
index 000000000..b0ab22c55
--- /dev/null
+++ b/user/opengfx/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=opengfx
+pkgver=0.5.4
+pkgrel=0
+pkgdesc="Graphics files for OpenTTD"
+url="https://www.openttd.org/en/"
+arch="noarch"
+options="!check" # Requires GIMP
+license="GPL-2.0-only"
+depends=""
+makedepends="grfcodec nml"
+subpackages=""
+source="http://bundles.openttdcoop.org/opengfx/releases/$pkgver/$pkgname-$pkgver-source.tar.xz
+ Makefile.patch
+ "
+builddir="$srcdir/$pkgname-$pkgver-source"
+
+build() {
+ cd "$builddir"
+ make GIMP="" _V="" bundle_tar
+}
+
+package() {
+ cd "$builddir"
+ local _file
+ for _file in *.grf opengfx.obg; do
+ install -D -m644 -g games $_file \
+ "$pkgdir"/usr/share/games/openttd/data/$_file
+ done
+}
+
+sha512sums="42f8438c747b42a77cf9d86c5da60ce3ce84ed347d714c345f3871806f9e35f2ed4729b445e0ee319f3e2edd53458dfbaad5ca42e389c3a2e800bce19223cdb1 opengfx-0.5.4-source.tar.xz
+f2cd513b6b244fcdd522e488c3becd27164f622f0bc723bd1f704ce1e76419ac628425cf3fc437beb50f851735923e85eae8a3f70e828f58edff4d632784bbf9 Makefile.patch"