summaryrefslogtreecommitdiff
path: root/user/openjdk7/gcc-fix-cxxflags-passing.patch
diff options
context:
space:
mode:
Diffstat (limited to 'user/openjdk7/gcc-fix-cxxflags-passing.patch')
-rw-r--r--user/openjdk7/gcc-fix-cxxflags-passing.patch10
1 files changed, 10 insertions, 0 deletions
diff --git a/user/openjdk7/gcc-fix-cxxflags-passing.patch b/user/openjdk7/gcc-fix-cxxflags-passing.patch
new file mode 100644
index 000000000..8eb1de77d
--- /dev/null
+++ b/user/openjdk7/gcc-fix-cxxflags-passing.patch
@@ -0,0 +1,10 @@
+--- gcc-4.8.1/Makefile.in.orig
++++ gcc-4.8.1/Makefile.in
+@@ -169,6 +169,7 @@
+ # built for the build system to override those in BASE_FLAGS_TO_PASSS.
+ EXTRA_BUILD_FLAGS = \
+ CFLAGS="$(CFLAGS_FOR_BUILD)" \
++ CXXFLAGS="$(CXXFLAGS_FOR_BUILD)" \
+ LDFLAGS="$(LDFLAGS_FOR_BUILD)"
+
+ # This is the list of directories to built for the host system.