summaryrefslogtreecommitdiff
path: root/user/perl-b-hooks-op-check
diff options
context:
space:
mode:
Diffstat (limited to 'user/perl-b-hooks-op-check')
-rw-r--r--user/perl-b-hooks-op-check/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/user/perl-b-hooks-op-check/APKBUILD b/user/perl-b-hooks-op-check/APKBUILD
new file mode 100644
index 000000000..93b27f9dd
--- /dev/null
+++ b/user/perl-b-hooks-op-check/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
+pkgname=perl-b-hooks-op-check
+pkgver=0.22
+pkgrel=0
+pkgdesc="Perl module for wrapping OP check callbacks in XS"
+url="https://metacpan.org/pod/B::Hooks::OP::Check"
+arch="all"
+license="Artistic-1.0-Perl"
+depends=""
+makedepends="perl-dev perl-extutils-depends"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/E/ET/ETHER/B-Hooks-OP-Check-$pkgver.tar.gz"
+builddir="$srcdir/B-Hooks-OP-Check-$pkgver"
+
+build() {
+ cd "$builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="e68b08a34244afc73d7d3b2b0acdf8fe791b0b1f087b6b0496da0a1e655a9e51552ec8fb0f743c8626a0414fb469a2133d113ff5b4ba9f96217cc87bef877542 B-Hooks-OP-Check-0.22.tar.gz"