summaryrefslogtreecommitdiff
path: root/user/perl-cwd-guard/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/perl-cwd-guard/APKBUILD')
-rw-r--r--user/perl-cwd-guard/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/user/perl-cwd-guard/APKBUILD b/user/perl-cwd-guard/APKBUILD
new file mode 100644
index 000000000..5976741ef
--- /dev/null
+++ b/user/perl-cwd-guard/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Dan Theisen <djt@hxx.in>
+# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
+pkgname=perl-cwd-guard
+pkgver=0.05
+pkgrel=0
+pkgdesc="Temporary changing working directory (chdir)"
+url="https://metacpan.org/pod/Cwd::Guard"
+arch="noarch"
+license="Artistic-1.0-Perl AND GPL-2.0"
+depends="perl"
+makedepends="perl-dev perl-module-build"
+checkdepends="perl-test-requires"
+install=""
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/K/KA/KAZEBURO/Cwd-Guard-$pkgver.tar.gz"
+builddir="$srcdir/Cwd-Guard-$pkgver"
+
+prepare() {
+ cd "$builddir"
+ perl Build.PL installdirs=vendor
+}
+
+build() {
+ cd "$builddir"
+ ./Build
+}
+
+check() {
+ cd "$builddir"
+ ./Build test
+}
+
+package() {
+ cd "$builddir"
+ ./Build install destdir="$pkgdir"
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="14aa68e535cec8f7182d5648558c539cbf6eebe2fee9c59d0b06f5b45cca1c6c652104a58f71b5a56f796f03d139e3e74962e45fb127bf038803b05cb9f32b82 Cwd-Guard-0.05.tar.gz"