summaryrefslogtreecommitdiff
path: root/user/perl-getopt-long-descriptive/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/perl-getopt-long-descriptive/APKBUILD')
-rw-r--r--user/perl-getopt-long-descriptive/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/user/perl-getopt-long-descriptive/APKBUILD b/user/perl-getopt-long-descriptive/APKBUILD
index c242ee5ce..e0bffefdf 100644
--- a/user/perl-getopt-long-descriptive/APKBUILD
+++ b/user/perl-getopt-long-descriptive/APKBUILD
@@ -1,6 +1,10 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-getopt-long-descriptive
+_pkgreal=Getopt-Long-Descriptive
+_author=RJBS
+_au=${_author%%"${_author#??}"}
+_a=${_author%%"${_author#?}"}
pkgver=0.104
pkgrel=0
pkgdesc="Simpler Perl implementation of Getopt::Long"
@@ -11,8 +15,8 @@ depends="perl-params-validate perl-sub-exporter"
makedepends="perl-dev"
checkdepends="perl-cpan-meta-check perl-test-fatal perl-test-warnings"
subpackages="$pkgname-doc"
-source="https://cpan.metacpan.org/authors/id/R/RJ/RJBS/Getopt-Long-Descriptive-$pkgver.tar.gz"
-builddir="$srcdir/Getopt-Long-Descriptive-$pkgver"
+source="https://cpan.metacpan.org/authors/id/$_a/$_au/$_author/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
build() {
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor