summaryrefslogtreecommitdiff
path: root/user/perl-html-formattext-withlinks/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/perl-html-formattext-withlinks/APKBUILD')
-rw-r--r--user/perl-html-formattext-withlinks/APKBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/user/perl-html-formattext-withlinks/APKBUILD b/user/perl-html-formattext-withlinks/APKBUILD
index 472ccad5b..656a4cf5b 100644
--- a/user/perl-html-formattext-withlinks/APKBUILD
+++ b/user/perl-html-formattext-withlinks/APKBUILD
@@ -1,7 +1,10 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-html-formattext-withlinks
-_pkgname=HTML-FormatText-WithLinks
+_pkgreal=HTML-FormatText-WithLinks
+_author=STRUAN
+_au=${_author%%"${_author#??}"}
+_a=${_author%%"${_author#?}"}
pkgver=0.15
pkgrel=0
pkgdesc="Perl-based HTML-to-text converter with links as footnotes"
@@ -11,22 +14,19 @@ license="Artistic-1.0-Perl OR GPL-2.0-only"
depends="perl-html-formatter perl-html-tree perl-uri"
makedepends="perl-dev"
subpackages="$pkgname-doc"
-source="https://cpan.metacpan.org/authors/id/S/ST/STRUAN/HTML-FormatText-WithLinks-$pkgver.tar.gz"
-builddir="$srcdir/HTML-FormatText-WithLinks-$pkgver"
+source="https://cpan.metacpan.org/authors/id/$_a/$_au/$_author/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
build() {
- cd "$builddir"
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd "$builddir"
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}