summaryrefslogtreecommitdiff
path: root/user/perl-inline-c/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/perl-inline-c/APKBUILD')
-rw-r--r--user/perl-inline-c/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/user/perl-inline-c/APKBUILD b/user/perl-inline-c/APKBUILD
index 480ebab83..b6fb45555 100644
--- a/user/perl-inline-c/APKBUILD
+++ b/user/perl-inline-c/APKBUILD
@@ -1,6 +1,10 @@
# Contributor: Dan Theisen <djt@hxx.in>
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-inline-c
+_pkgreal=Inline-C
+_author=TINITA
+_au=${_author%%"${_author#??}"}
+_a=${_author%%"${_author#?}"}
pkgver=0.81
pkgrel=0
pkgdesc="C language support for Inline"
@@ -11,8 +15,8 @@ depends="perl perl-inline perl-pegex perl-parse-recdescent"
makedepends="perl-dev perl-file-sharedir-install"
checkdepends="perl-test-warn perl-yaml-libyaml perl-file-copy-recursive"
subpackages="$pkgname-doc"
-source="https://cpan.metacpan.org/authors/id/T/TI/TINITA/Inline-C-$pkgver.tar.gz"
-builddir="$srcdir/Inline-C-$pkgver"
+source="https://cpan.metacpan.org/authors/id/$_a/$_au/$_author/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
build() {
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor