summaryrefslogtreecommitdiff
path: root/user/perl-specio/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/perl-specio/APKBUILD')
-rw-r--r--user/perl-specio/APKBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/user/perl-specio/APKBUILD b/user/perl-specio/APKBUILD
index 43cdeb30b..00eabaa23 100644
--- a/user/perl-specio/APKBUILD
+++ b/user/perl-specio/APKBUILD
@@ -1,6 +1,10 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-specio
+_pkgreal=Specio
+_author=DROLSKY
+_au=${_author%%"${_author#??}"}
+_a=${_author%%"${_author#?}"}
pkgver=0.44
pkgrel=0
pkgdesc="Type constraints and coercions for Perl"
@@ -10,11 +14,11 @@ license="Artistic-2.0"
depends="perl-devel-stacktrace perl-eval-closure perl-mro-compat
perl-module-runtime perl-role-tiny perl-sub-quote perl-test-fatal
perl-try-tiny"
-makedepends="perl-dev"
+makedepends=""
checkdepends="perl-test-needs"
subpackages="$pkgname-doc"
-source="https://cpan.metacpan.org/authors/id/D/DR/DROLSKY/Specio-$pkgver.tar.gz"
-builddir="$srcdir/Specio-$pkgver"
+source="https://cpan.metacpan.org/authors/id/$_a/$_au/$_author/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
build() {
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor