summaryrefslogtreecommitdiff
path: root/user/perl-test-script/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/perl-test-script/APKBUILD')
-rw-r--r--user/perl-test-script/APKBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/user/perl-test-script/APKBUILD b/user/perl-test-script/APKBUILD
index 11eb89603..0963e18d5 100644
--- a/user/perl-test-script/APKBUILD
+++ b/user/perl-test-script/APKBUILD
@@ -1,32 +1,32 @@
# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-test-script
+_pkgreal=Test-Script
+_author=PLICEASE
+_au=${_author%%"${_author#??}"}
+_a=${_author%%"${_author#?}"}
pkgver=1.25
pkgrel=0
pkgdesc="Perl module for cross-platform script testing"
url="https://metacpan.org/pod/Test::Script"
arch="noarch"
license="Artistic-1.0-Perl"
-depends="perl perl-capture-tiny perl-probe-perl perl-test2-suite"
+depends="perl-capture-tiny perl-probe-perl perl-test2-suite"
makedepends=""
-install=""
subpackages="$pkgname-doc"
-source="https://cpan.metacpan.org/authors/id/P/PL/PLICEASE/Test-Script-$pkgver.tar.gz"
-builddir="$srcdir/Test-Script-$pkgver"
+source="https://cpan.metacpan.org/authors/id/$_a/$_au/$_author/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
build() {
- cd "$builddir"
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd "$builddir"
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}