summaryrefslogtreecommitdiff
path: root/user/plasma-desktop/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/plasma-desktop/APKBUILD')
-rw-r--r--user/plasma-desktop/APKBUILD21
1 files changed, 10 insertions, 11 deletions
diff --git a/user/plasma-desktop/APKBUILD b/user/plasma-desktop/APKBUILD
index 4d7883931..afa6daf78 100644
--- a/user/plasma-desktop/APKBUILD
+++ b/user/plasma-desktop/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox-kde@adelielinux.org>
pkgname=plasma-desktop
-pkgver=5.12.8
+pkgver=5.17.90
pkgrel=0
pkgdesc="Modern, functional, integrated libre desktop environment"
url="https://www.kde.org/plasma-desktop"
@@ -9,25 +9,25 @@ arch="all"
options="!check" # Test suite fails due to keyboard layouts
license="GPL-2.0 LGPL-2.1"
# theme/visual dependencies
-depends="breeze breeze-icons oxygen ttf-liberation"
+depends="breeze breeze-icons kirigami2 oxygen qt5-qtquickcontrols2
+ ttf-liberation"
# shell/QML dependencies
depends="$depends kde-cli-tools kded kwin qt5-qtgraphicaleffects setxkbmap"
# Good Ideas™ to have
-depends="$depends consolekit kdeclarative"
+depends="$depends consolekit2 kdeclarative"
makedepends="cmake qt5-qtbase-dev qt5-qtdeclarative-dev qt5-qtx11extras-dev
qt5-qtsvg-dev kdelibs4support-dev xf86-input-synaptics-dev
- kauth-dev plasma-framework-dev kdoctools-dev ki18n-dev
+ kauth-dev plasma-framework-dev kdoctools-dev ki18n-dev libkworkspace-dev
kcmutils-dev knewstuff-dev knotifications-dev knotifyconfig-dev
attica-dev kwallet-dev krunner-dev kglobalaccel-dev kdeclarative-dev
kpeople-dev kdbusaddons-dev kactivities-dev kactivities-stats-dev
kconfig-dev kitemmodels-dev plasma-workspace-dev xf86-input-evdev-dev
libxkbcommon-dev pulseaudio-dev libcanberra-dev libxkbfile-dev
xorg-server-dev kwin-dev kscreenlocker-dev baloo-dev xcb-util-image-dev
- xf86-input-libinput-dev breeze-dev xkeyboard-config extra-cmake-modules"
+ xf86-input-libinput-dev breeze-dev xkeyboard-config extra-cmake-modules
+ kirigami2-dev libksysguard-dev qt5-qtquickcontrols2-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-source="https://download.kde.org/stable/plasma/$pkgver/plasma-desktop-$pkgver.tar.xz
- cmake-fixes.patch
- "
+source="https://download.kde.org/unstable/plasma/$pkgver/plasma-desktop-$pkgver.tar.xz"
build() {
if [ "$CBUILD" != "$CHOST" ]; then
@@ -41,7 +41,7 @@ build() {
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
-DCMAKE_C_FLAGS="$CFLAGS" \
-DBUILD_TESTING=OFF \
- ${CMAKE_CROSSOPTS}
+ ${CMAKE_CROSSOPTS} .
make
}
@@ -53,5 +53,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="dc55d9a894c52c44cd2aff844793e038dd66854862a212d47dfb0144dd489c3ae8d2c4e289a1e76c3d31ca68a8543bb511623f96617db799d28009736591c58f plasma-desktop-5.12.8.tar.xz
-45119bbd7b6f7803323410acac6c5cb2be232f776e6009938e932976091ca188f4a52ba0bca814212353856a8eb87700d86b2452d9cb925c4f6f1bf3577065b7 cmake-fixes.patch"
+sha512sums="8d62506fbe2c276e26a21e107efa192661c9839b94762595b465f515867ba13b17265a3f193ccab2523812c62da5c6c4900fa8f25c50f9ae63e1a5883db97c1b plasma-desktop-5.17.90.tar.xz"