summaryrefslogtreecommitdiff
path: root/user/plasma-workspace
diff options
context:
space:
mode:
Diffstat (limited to 'user/plasma-workspace')
-rw-r--r--user/plasma-workspace/APKBUILD19
-rw-r--r--user/plasma-workspace/cmake-fixes.patch89
-rw-r--r--user/plasma-workspace/header.patch97
-rw-r--r--user/plasma-workspace/libkworkspace.patch35
-rw-r--r--user/plasma-workspace/session-conflict.patch91
5 files changed, 43 insertions, 288 deletions
diff --git a/user/plasma-workspace/APKBUILD b/user/plasma-workspace/APKBUILD
index 0bb3216e4..971458789 100644
--- a/user/plasma-workspace/APKBUILD
+++ b/user/plasma-workspace/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox-kde@adelielinux.org>
pkgname=plasma-workspace
-pkgver=5.12.9
+pkgver=5.17.90
pkgrel=0
pkgdesc="KDE Plasma 5 workspace"
url="https://www.kde.org/plasma-desktop"
@@ -21,19 +21,18 @@ depends_dev="qt5-qtbase-dev qt5-qtdeclarative-dev kdelibs4support-dev
kitemmodels-dev kservice-dev kwindowsystem-dev"
makedepends="$depends_dev cmake extra-cmake-modules qt5-qtscript-dev
iso-codes-dev libdbusmenu-qt-dev libqalculate-dev libxtst-dev
- xcb-util-image-dev
+ xcb-util-image-dev libkworkspace-dev
baloo-dev kactivities-dev kcmutils-dev kcrash-dev kdbusaddons-dev
kdeclarative-dev kdesu-dev kdoctools-dev kglobalaccel-dev kholidays-dev
kidletime-dev kjsembed-dev knewstuff-dev knotifyconfig-dev kpackage-dev
krunner-dev kscreenlocker-dev ktexteditor-dev ktextwidgets-dev
kwallet-dev kwayland-dev kwin-dev kxmlrpcclient-dev libksysguard-dev
- plasma-framework-dev prison-dev"
+ plasma-framework-dev prison-dev kactivities-stats-dev kpeople-dev
+ kirigami2-dev kuserfeedback-dev libkscreen-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-source="https://download.kde.org/stable/plasma/$pkgver/plasma-workspace-$pkgver.tar.xz
- cmake-fixes.patch
- header.patch
- session-conflict.patch
+source="https://download.kde.org/unstable/plasma/$pkgver/plasma-workspace-$pkgver.tar.xz
+ libkworkspace.patch
"
build() {
@@ -60,7 +59,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="d96df6642f8d4c134381d8b186ec8766f0dffa3ebeb11f32242817d500e805e4d6c8df1471b1bdeb95a7778b6e9cd0daf1f72c04f834cc35bd14f1be9749e705 plasma-workspace-5.12.9.tar.xz
-148195f34938c8f2ffd80d25bc07725e4e2a64296ec6292f7d8e739f1ab535f676683aa5d0ad41e1e085394ce733f5d25727cf44d55010488b8139ca9c9af135 cmake-fixes.patch
-9934721c58ed514e55365a9b2e0410ee76fcf444a660ce9086d3aa46ca9fea708866e53c2f33a33a79ea4af13edee102a8bea9ca0bd280a6306527b6e5f46dd5 header.patch
-2212bcafc53d6c9688265aed8ebceddeec23f6e73804ece955ac4006beb862dccbd93076ab357bbbef2d0953976a3347c8a1e5d2fa2654b5a7120abc288ea8ba session-conflict.patch"
+sha512sums="8fc014e90dca30b54122ef0e83c08faabbb41a3ba5a511e4713db3898acd18faf53652ff766ffbaa70d1da3053618b70882255afeca060cd92e06d0bdf4e1934 plasma-workspace-5.17.90.tar.xz
+f58b88928fd68518bc0524db35388cb0f0dbc2a55d85fc47e92ce7fcbaf9b155482736e282bd84104ceecc625406845840128c8d0fcd2a4d5a854673964cd94f libkworkspace.patch"
diff --git a/user/plasma-workspace/cmake-fixes.patch b/user/plasma-workspace/cmake-fixes.patch
deleted file mode 100644
index 68ad943f1..000000000
--- a/user/plasma-workspace/cmake-fixes.patch
+++ /dev/null
@@ -1,89 +0,0 @@
-From c534fdf1ba34d0ea8a08b9b5266384a3243271e0 Mon Sep 17 00:00:00 2001
-From: David Faure <faure@kde.org>
-Date: Sun, 10 Feb 2019 20:21:57 +0100
-Subject: Harmonize usage of HAVE_X11, using #if and #cmakedefine01 everywhere
-
-I got "#define HAVE_X11 TRUE" and errors because of that where #if was
-used.
-
-This also obeys the logic that HAVE_X11 is set (in the toplevel
-CMakeLists.txt) not only when X11_FOUND but also when XCB is found.
----
- appmenu/appmenu.cpp | 2 +-
- config-X11.h.cmake | 2 +-
- libkworkspace/config-libkworkspace.h.cmake | 2 +-
- runners/windows/config-windowsrunner.h.cmake | 2 +-
- shell/scripting/appinterface.cpp | 2 +-
- soliduiserver/soliduiserver.cpp | 2 +-
- 6 files changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/appmenu/appmenu.cpp b/appmenu/appmenu.cpp
-index 7c956c6..4ab7106 100644
---- a/appmenu/appmenu.cpp
-+++ b/appmenu/appmenu.cpp
-@@ -106,7 +106,7 @@ AppMenuModule::~AppMenuModule() = default;
-
- void AppMenuModule::slotWindowRegistered(WId id, const QString &serviceName, const QDBusObjectPath &menuObjectPath)
- {
--#ifdef HAVE_X11
-+#if HAVE_X11
- if (KWindowSystem::isPlatformX11()) {
- auto *c = QX11Info::connection();
-
-diff --git a/config-X11.h.cmake b/config-X11.h.cmake
-index 60286dd..ae8978a 100644
---- a/config-X11.h.cmake
-+++ b/config-X11.h.cmake
-@@ -41,4 +41,4 @@
- #cmakedefine HAS_RANDR_1_3 1
-
- /* Define if you have X11 at all */
--#define HAVE_X11 ${X11_FOUND}
-+#cmakedefine01 HAVE_X11
-diff --git a/libkworkspace/config-libkworkspace.h.cmake b/libkworkspace/config-libkworkspace.h.cmake
-index 36a826e..c3ae6d7 100644
---- a/libkworkspace/config-libkworkspace.h.cmake
-+++ b/libkworkspace/config-libkworkspace.h.cmake
-@@ -1,2 +1,2 @@
- /* Define if you have X11 at all */
--#define HAVE_X11 ${X11_FOUND}
-\ No newline at end of file
-+#cmakedefine01 HAVE_X11
-diff --git a/runners/windows/config-windowsrunner.h.cmake b/runners/windows/config-windowsrunner.h.cmake
-index 36a826e..c3ae6d7 100644
---- a/runners/windows/config-windowsrunner.h.cmake
-+++ b/runners/windows/config-windowsrunner.h.cmake
-@@ -1,2 +1,2 @@
- /* Define if you have X11 at all */
--#define HAVE_X11 ${X11_FOUND}
-\ No newline at end of file
-+#cmakedefine01 HAVE_X11
-diff --git a/shell/scripting/appinterface.cpp b/shell/scripting/appinterface.cpp
-index bd66cd2..a0ad73c 100644
---- a/shell/scripting/appinterface.cpp
-+++ b/shell/scripting/appinterface.cpp
-@@ -37,7 +37,7 @@
- #include <windows.h>
- #endif
-
--#ifdef HAVE_X11
-+#if HAVE_X11
- #include <X11/Xlib.h>
- #include <fixx11h.h>
- #endif
-diff --git a/soliduiserver/soliduiserver.cpp b/soliduiserver/soliduiserver.cpp
-index 3ec09c0..d06a1e6 100644
---- a/soliduiserver/soliduiserver.cpp
-+++ b/soliduiserver/soliduiserver.cpp
-@@ -222,7 +222,7 @@ void SolidUiServer::reparentDialog(QWidget *dialog, WId wId, const QString &appI
-
- KWindowSystem::setMainWindow(dialog, wId); // correct, set dialog parent
-
--#ifdef HAVE_X11
-+#if HAVE_X11
- if (modal) {
- KWindowSystem::setState(dialog->winId(), NET::Modal);
- } else {
---
-cgit v1.1
-
diff --git a/user/plasma-workspace/header.patch b/user/plasma-workspace/header.patch
deleted file mode 100644
index ea82bd7f0..000000000
--- a/user/plasma-workspace/header.patch
+++ /dev/null
@@ -1,97 +0,0 @@
-From a788ab3d08a8a68ed232f81a2110f447080451ec Mon Sep 17 00:00:00 2001
-From: Laurent Montel <montel@kde.org>
-Date: Thu, 8 Aug 2019 13:54:17 +0200
-Subject: Add missing include
-
----
- shell/shellcorona.cpp | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/shell/shellcorona.cpp b/shell/shellcorona.cpp
-index 90fd4f9..5c94e32 100644
---- a/shell/shellcorona.cpp
-+++ b/shell/shellcorona.cpp
-@@ -30,6 +30,7 @@
- #include <QQmlContext>
- #include <QDBusConnection>
- #include <QUrl>
-+#include <QScreen>
-
- #include <QJsonObject>
- #include <QJsonDocument>
---
-cgit v1.1
-
-From b98a399bdcdb7f0ca84298bad96b1a13ed8b5d1f Mon Sep 17 00:00:00 2001
-From: Nate Graham <nate@kde.org>
-Date: Thu, 8 Aug 2019 07:54:35 -0600
-Subject: Fix build failure in the CI
-
----
- runners/windows/windowsrunner.cpp | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/runners/windows/windowsrunner.cpp b/runners/windows/windowsrunner.cpp
-index 70856f7..4fc4aaf 100644
---- a/runners/windows/windowsrunner.cpp
-+++ b/runners/windows/windowsrunner.cpp
-@@ -24,6 +24,7 @@
-
- #include <QDebug>
- #include <QIcon>
-+#include <QMutexLocker>
- #include <KWindowSystem>
- #include <KLocalizedString>
-
---
-cgit v1.1
-
-From 0c4ec1c4af05aa1f6e36c934881cf6f427f7241a Mon Sep 17 00:00:00 2001
-From: Nate Graham <nate@kde.org>
-Date: Tue, 6 Aug 2019 13:29:56 -0600
-Subject: Fix compilation
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Summary:
-Without this patch, plasma-workspace fails to compile for me with the following error:
-```
-In file included from /home/nate/kde/build/plasma-workspace/runners/windows/krunner_windows_autogen/EWIEGA46WW/moc_windowsrunner.cpp:10,
- from /home/nate/kde/build/plasma-workspace/runners/windows/krunner_windows_autogen/mocs_compilation.cpp:2:
-/home/nate/kde/build/plasma-workspace/runners/windows/krunner_windows_autogen/EWIEGA46WW/../../../../../../src/plasma-workspace/runners/windows/windowsrunner.h:61:9: error: ‘QMutex’ does not name a type
- 61 | QMutex m_mutex;
- | ^~~~~~
-```
-
-Test Plan: It compiles now
-
-Reviewers: #plasma, aacid
-
-Reviewed By: aacid
-
-Subscribers: plasma-devel
-
-Tags: #plasma
-
-Differential Revision: https://phabricator.kde.org/D22976
----
- runners/windows/windowsrunner.h | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/runners/windows/windowsrunner.h b/runners/windows/windowsrunner.h
-index 016b7c4..a106af8 100644
---- a/runners/windows/windowsrunner.h
-+++ b/runners/windows/windowsrunner.h
-@@ -21,6 +21,8 @@
-
- #include <KRunner/AbstractRunner>
-
-+#include <QMutex>
-+
- class KWindowInfo;
-
- class WindowsRunner : public Plasma::AbstractRunner
---
-cgit v1.1
-
diff --git a/user/plasma-workspace/libkworkspace.patch b/user/plasma-workspace/libkworkspace.patch
new file mode 100644
index 000000000..e8e3d93b6
--- /dev/null
+++ b/user/plasma-workspace/libkworkspace.patch
@@ -0,0 +1,35 @@
+From 4717089b68c386446be240f463f2f13e7024468b Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Mon, 22 Oct 2018 10:35:10 +0200
+Subject: [PATCH] libkworkspace: Allow standalone build
+
+---
+ CMakeLists.txt | 6 +++-
+ 1 file changed, 5 insertions(+), 1 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index e587a386..d1a63527 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -63,6 +63,7 @@ set_package_properties(KF5Baloo PROPERTIES DESCRIPTION "File Searching"
+
+ find_package(KF5TextEditor)
+ find_package(KWinDBusInterface CONFIG REQUIRED)
++find_package(LibKWorkspace 5.17.90)
+
+ find_package(KScreenLocker 5.17.90 REQUIRED)
+ find_package(ScreenSaverDBusInterface CONFIG REQUIRED)
+@@ -151,7 +151,10 @@ endif()
+ add_definitions(-DQT_NO_URL_CAST_FROM_STRING)
+
+ add_subdirectory(doc)
+-add_subdirectory(libkworkspace)
++if(NOT LibKWorkspace_FOUND)
++ message(STATUS "System LibKWorkspace not found, using bundled.")
++ add_subdirectory(libkworkspace)
++endif()
+ add_subdirectory(libdbusmenuqt)
+ add_subdirectory(appmenu)
+
+--
+2.19.1
diff --git a/user/plasma-workspace/session-conflict.patch b/user/plasma-workspace/session-conflict.patch
deleted file mode 100644
index 667a7187b..000000000
--- a/user/plasma-workspace/session-conflict.patch
+++ /dev/null
@@ -1,91 +0,0 @@
-From 36bc9bfd9661f88039a8945688e07b0626b48610 Mon Sep 17 00:00:00 2001
-From: Andreas Sturmlechner <asturm@gentoo.org>
-Date: Tue, 15 Oct 2019 18:33:45 +0200
-Subject: [PATCH 1/2] Fix Name conflict between plasma.desktop and
- plasmawayland.desktop
-
-Summary:
-SDDM until 0.18.1 appends " (Wayland)" to the name of any session file it
-finds in wayland-sessions dir, and Plasma is relying on that behaviour to
-distinguish between its X11 and Wayland sessions. This leads to duplicate
-"Plasma" entries on any other DM not applying the same hack, e.g. lightdm,
-and users are lost without downstream patching.
-
-SDDM in 0.19 only appends " (Wayland)" in case the session name does
-not already end with this, to avoid duplicating it.
-
-CCBUG: https://bugs.kde.org/show_bug.cgi?id=368409
-See also: https://github.com/sddm/sddm/pull/997
-
-Reviewers: #plasma, davidedmundson, fvogt, ngraham
-
-Reviewed By: #plasma, davidedmundson, fvogt, ngraham
-
-Subscribers: ngraham, pino, rdieter, fvogt, davidedmundson, plasma-devel
-
-Tags: #plasma
-
-Differential Revision: https://phabricator.kde.org/D22210
----
- login-sessions/plasmawayland.desktop.cmake | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/plasmawayland.desktop.cmake b/plasmawayland.desktop.cmake
-index 64f997ea4..3e9b46bc9 100644
---- a/plasmawayland.desktop.cmake
-+++ b/plasmawayland.desktop.cmake
-@@ -2,51 +2,7 @@
- Exec=dbus-run-session ${CMAKE_INSTALL_FULL_BINDIR}/startplasma-wayland
- TryExec=${CMAKE_INSTALL_FULL_BINDIR}/startplasma-wayland
- DesktopNames=KDE
--Name=Plasma
--Name[ar]=بلازما
--Name[bs]=Plazma
--Name[ca]=Plasma
--Name[ca@valencia]=Plasma
--Name[cs]=Plasma
--Name[da]=Plasma
--Name[de]=Plasma
--Name[el]=Plasma
--Name[en_GB]=Plasma
--Name[es]=Plasma
--Name[et]=Plasma
--Name[eu]=Plasma
--Name[fi]=Plasma
--Name[fr]=Plasma
--Name[gl]=Plasma
--Name[he]=פלזמה
--Name[hu]=Plasma
--Name[id]=Plasma
--Name[is]=Plasma
--Name[it]=Plasma
--Name[ja]=プラズマ
--Name[ko]=Plasma
--Name[lt]=Plasma
--Name[nb]=Plasma
--Name[nds]=Plasma
--Name[nl]=Plasma
--Name[nn]=Plasma
--Name[pa]=ਪਲਾਜ਼ਮਾ
--Name[pl]=Plazma
--Name[pt]=Plasma
--Name[pt_BR]=Plasma
--Name[ru]=Plasma
--Name[sk]=Plasma
--Name[sl]=Plasma
--Name[sr]=Плазма
--Name[sr@ijekavian]=Плазма
--Name[sr@ijekavianlatin]=Plasma
--Name[sr@latin]=Plasma
--Name[sv]=Plasma
--Name[tr]=Plama
--Name[uk]=Плазма
--Name[x-test]=xxPlasmaxx
--Name[zh_CN]=Plasma
--Name[zh_TW]=Plasma
-+Name=Plasma (Wayland)
- Comment=Plasma by KDE
- Comment[ar]=بلازما كدي
- Comment[bs]=Plazma od strane KDe
---
-2.23.0