summaryrefslogtreecommitdiff
path: root/user/plib
diff options
context:
space:
mode:
Diffstat (limited to 'user/plib')
-rw-r--r--user/plib/APKBUILD54
-rw-r--r--user/plib/fix-openflight.patch25
-rw-r--r--user/plib/joystick.patch31
-rw-r--r--user/plib/plib-1.8.5-CVE-2011-4620.patch11
-rw-r--r--user/plib/plib-1.8.5-CVE-2012-4552.patch54
-rw-r--r--user/plib/shared.patch288
6 files changed, 463 insertions, 0 deletions
diff --git a/user/plib/APKBUILD b/user/plib/APKBUILD
new file mode 100644
index 000000000..fe02621ac
--- /dev/null
+++ b/user/plib/APKBUILD
@@ -0,0 +1,54 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=plib
+pkgver=1.8.5
+pkgrel=0
+pkgdesc="Portable game libraries"
+url="http://plib.sourceforge.net/"
+arch="all"
+options="!dbg" # No shared libraries
+license="LGPL-2.0+"
+depends=""
+makedepends="libxi-dev libxmu-dev libxt-dev mesa-dev"
+subpackages="$pkgname-dev"
+source="http://plib.sourceforge.net/dist/plib-$pkgver.tar.gz
+ fix-openflight.patch
+ joystick.patch
+ plib-1.8.5-CVE-2011-4620.patch
+ plib-1.8.5-CVE-2012-4552.patch
+ shared.patch
+ "
+
+prepare() {
+ default_prepare
+ autoreconf -vif
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="17154cc77243fe576c2bcbcb0285b98aef1a0634658f5473e95fe0ac8fa3ed477dbe5620e44ccf0b7cc616f812af0cd44d6fcbba0c563180d3b61c9d6f158e1d plib-1.8.5.tar.gz
+fac9c78a57a0c564c46d586ebf541b45cf7dc838387498f3263bac78f0f78c53c85000667d6dfd349e328b1cd4254ac0d786dd825aefbe957f94e6d3b91ec41b fix-openflight.patch
+d9909c81fe2ed696c639623c532cb16a1378b0e2843ccbef00bb16bc6459cc7c708b2b0903dbdc89e6fb05522debd79f0f88b311bf12c3d415e303591033f0a8 joystick.patch
+c046cf65e80629f238aaba724f522c31b434f5c9687ea02b019846ce3469c6b074bd014f81a7a4e6b43db7b084f4dcd9d4c04b557dbc1b8b8ca00f2d782fdf1c plib-1.8.5-CVE-2011-4620.patch
+a09462ecb085703aae7cd3b77954cc800410aa37a9616255cca2f21456e6d5dcf8ead3f684c98236deb1455c6a034dc8ec874bafdbab003f7a63517ea1f8350d plib-1.8.5-CVE-2012-4552.patch
+8f4fcbf3a07f64212b3ce891a4629fb45b1c62b251730a9d5f7da6e6fe65c39540f80519e97cf6a45c32f950f25e4d383ba891a6c0a92ae8a37089e51c0c5020 shared.patch"
diff --git a/user/plib/fix-openflight.patch b/user/plib/fix-openflight.patch
new file mode 100644
index 000000000..7c69c1cd1
--- /dev/null
+++ b/user/plib/fix-openflight.patch
@@ -0,0 +1,25 @@
+--- plib-1.8.5/src/ssg/ssgLoadFLT.cxx.old 2008-03-11 02:06:23.000000000 +0000
++++ plib-1.8.5/src/ssg/ssgLoadFLT.cxx 2018-10-23 22:02:06.650000000 +0000
+@@ -103,9 +103,7 @@
+ #include <string.h>
+ #include <fcntl.h>
+ #include <stdio.h>
+-#ifdef UL_IRIX
+-# include <sys/endian.h>
+-#endif
++#include <endian.h>
+ #ifdef USE_POSIX_MMAP
+ # include <time.h>
+ # include <sys/time.h> /* Need both for Mandrake 8.0 !! */
+@@ -141,11 +139,8 @@
+ #define template _template /* trams */
+
+ typedef unsigned char ubyte;
+-
+-#ifdef UL_WIN32
+ typedef unsigned short ushort;
+ typedef unsigned int uint;
+-#endif
+
+ // 525 = negative identation, 539= did not expect positive identation
+ //lint -save -e525 -e539
diff --git a/user/plib/joystick.patch b/user/plib/joystick.patch
new file mode 100644
index 000000000..febcc89e3
--- /dev/null
+++ b/user/plib/joystick.patch
@@ -0,0 +1,31 @@
+Description: Don't break system calibration settings when a joystick is opened
+ plib may do additional dead-band management on top of the OS joystick driver,
+ it should not break system settings for that reason!
+Author: Florent Rougon <f.rougon@free.fr>
+Bug: https://sourceforge.net/p/plib/bugs/47/
+Bug-Debian: http://bugs.debian.org/787464
+Last-Update: 2015-06-01
+
+--- a/src/js/jsLinux.cxx
++++ b/src/js/jsLinux.cxx
+@@ -79,20 +79,6 @@
+ if ( num_axes > _JS_MAX_AXES )
+ num_axes = _JS_MAX_AXES ;
+
+- // Remove any deadband value already done in the kernel.
+- // Since we have our own deadband management this is save to do so.
+- struct js_corr* corr = new js_corr[ all_axes ] ;
+- ioctl ( os->fd, JSIOCGCORR, corr );
+- for ( int i = 0; i < num_axes ; ++i ) {
+- if ( corr[ i ] . type == JS_CORR_BROKEN ) {
+- int nodeadband = ( corr[ i ] . coef[ 0 ] + corr[ i ] . coef[ 1 ] ) / 2 ;
+- corr[ i ] . coef[ 0 ] = nodeadband ;
+- corr[ i ] . coef[ 1 ] = nodeadband ;
+- }
+- }
+- ioctl ( os->fd, JSIOCSCORR, corr );
+- delete [] corr;
+-
+ for ( int i = 0 ; i < _JS_MAX_AXES ; i++ )
+ {
+ max [ i ] = 32767.0f ;
diff --git a/user/plib/plib-1.8.5-CVE-2011-4620.patch b/user/plib/plib-1.8.5-CVE-2011-4620.patch
new file mode 100644
index 000000000..41fac5fe4
--- /dev/null
+++ b/user/plib/plib-1.8.5-CVE-2011-4620.patch
@@ -0,0 +1,11 @@
+--- plib-1.8.5/src/util/ulError.cxx~ 2008-03-11 03:06:23.000000000 +0100
++++ plib-1.8.5/src/util/ulError.cxx 2011-12-27 15:38:25.305676650 +0100
+@@ -39,7 +39,7 @@ void ulSetError ( enum ulSeverity severi
+ {
+ va_list argp;
+ va_start ( argp, fmt ) ;
+- vsprintf ( _ulErrorBuffer, fmt, argp ) ;
++ vsnprintf ( _ulErrorBuffer, sizeof(_ulErrorBuffer), fmt, argp ) ;
+ va_end ( argp ) ;
+
+ if ( _ulErrorCB )
diff --git a/user/plib/plib-1.8.5-CVE-2012-4552.patch b/user/plib/plib-1.8.5-CVE-2012-4552.patch
new file mode 100644
index 000000000..78f1b22ae
--- /dev/null
+++ b/user/plib/plib-1.8.5-CVE-2012-4552.patch
@@ -0,0 +1,54 @@
+--- plib-1.8.5/src/ssg/ssgParser.cxx~
++++ plib-1.8.5/src/ssg/ssgParser.cxx
+@@ -57,18 +57,16 @@ void _ssgParser::error( const char *form
+ char msgbuff[ 255 ];
+ va_list argp;
+
+- char* msgptr = msgbuff;
+- if (linenum)
+- {
+- msgptr += sprintf ( msgptr,"%s, line %d: ",
+- path, linenum );
+- }
+-
+ va_start( argp, format );
+- vsprintf( msgptr, format, argp );
++ vsnprintf( msgbuff, sizeof(msgbuff), format, argp );
+ va_end( argp );
+
+- ulSetError ( UL_WARNING, "%s", msgbuff ) ;
++ if (linenum)
++ {
++ ulSetError ( UL_WARNING, "%s, line %d: %s", path, linenum, msgbuff ) ;
++ } else {
++ ulSetError ( UL_WARNING, "%s", msgbuff ) ;
++ }
+ }
+
+
+@@ -78,18 +76,16 @@ void _ssgParser::message( const char *fo
+ char msgbuff[ 255 ];
+ va_list argp;
+
+- char* msgptr = msgbuff;
+- if (linenum)
+- {
+- msgptr += sprintf ( msgptr,"%s, line %d: ",
+- path, linenum );
+- }
+-
+ va_start( argp, format );
+- vsprintf( msgptr, format, argp );
++ vsnprintf( msgbuff, sizeof(msgbuff), format, argp );
+ va_end( argp );
+
+- ulSetError ( UL_DEBUG, "%s", msgbuff ) ;
++ if (linenum)
++ {
++ ulSetError ( UL_DEBUG, "%s, line %d: %s", path, linenum, msgbuff ) ;
++ } else {
++ ulSetError ( UL_DEBUG, "%s", msgbuff ) ;
++ }
+ }
+
+ // Opens the file and does a few internal calculations based on the spec.
diff --git a/user/plib/shared.patch b/user/plib/shared.patch
new file mode 100644
index 000000000..cb000310d
--- /dev/null
+++ b/user/plib/shared.patch
@@ -0,0 +1,288 @@
+diff -Naur plib-1.8.5.orig/configure.in plib-1.8.5/configure.in
+--- plib-1.8.5.orig/configure.in 2008-04-17 13:46:45.000000000 +0100
++++ plib-1.8.5/configure.in 2008-04-17 13:47:10.000000000 +0100
+@@ -36,7 +36,7 @@
+ AC_PROG_CXX
+ AC_PROG_CXXCPP
+ AC_PROG_INSTALL
+-AC_PROG_RANLIB
++AC_PROG_LIBTOOL
+
+ dnl Command line arguments
+
+diff -Naur plib-1.8.5.orig/src/fnt/Makefile.am plib-1.8.5/src/fnt/Makefile.am
+--- plib-1.8.5.orig/src/fnt/Makefile.am 2008-04-17 13:46:45.000000000 +0100
++++ plib-1.8.5/src/fnt/Makefile.am 2008-04-17 13:52:53.000000000 +0100
+@@ -1,10 +1,12 @@
+ if BUILD_FNT
+
+-lib_LIBRARIES = libplibfnt.a
++lib_LTLIBRARIES = libplibfnt.la
+
+ include_HEADERS = fnt.h
+
+-libplibfnt_a_SOURCES = fnt.cxx fntTXF.cxx fntLocal.h fntBitmap.cxx
++libplibfnt_la_SOURCES = fnt.cxx fntTXF.cxx fntLocal.h fntBitmap.cxx
++libplibfnt_la_LIBADD = ../util/libplibul.la
++libplibfnt_la_LDFLAGS = -version-info 9:5:8
+
+ INCLUDES = -I$(top_srcdir)/src/sg -I$(top_srcdir)/src/util
+
+diff -Naur plib-1.8.5.orig/src/js/Makefile.am plib-1.8.5/src/js/Makefile.am
+--- plib-1.8.5.orig/src/js/Makefile.am 2008-04-17 13:46:45.000000000 +0100
++++ plib-1.8.5/src/js/Makefile.am 2008-04-17 13:53:33.000000000 +0100
+@@ -1,12 +1,15 @@
+ if BUILD_JS
+
+-lib_LIBRARIES = libplibjs.a
++lib_LTLIBRARIES = libplibjs.la
+
+ include_HEADERS = js.h
+
+-libplibjs_a_SOURCES = js.cxx jsLinux.cxx jsLinuxOld.cxx jsMacOS.cxx \
++libplibjs_la_SOURCES = js.cxx jsLinux.cxx jsLinuxOld.cxx jsMacOS.cxx \
+ jsMacOSX.cxx jsWindows.cxx jsBSD.cxx \
+ jsNone.cxx
++libplibjs_la_LIBADD = ../util/libplibul.la
++libplibjs_la_LDFLAGS = -version-info 9:5:8
++
+
+ INCLUDES = -I$(top_srcdir)/src/util
+
+diff -Naur plib-1.8.5.orig/src/Makefile.am plib-1.8.5/src/Makefile.am
+--- plib-1.8.5.orig/src/Makefile.am 2008-04-17 13:46:45.000000000 +0100
++++ plib-1.8.5/src/Makefile.am 2008-04-17 14:16:21.000000000 +0100
+@@ -1 +1 @@
+-SUBDIRS = util js sl pui puAux sg ssg fnt ssgAux net psl pw
++SUBDIRS = util fnt sg js sl pui puAux ssg ssgAux net psl pw
+diff -Naur plib-1.8.5.orig/src/net/Makefile.am plib-1.8.5/src/net/Makefile.am
+--- plib-1.8.5.orig/src/net/Makefile.am 2008-04-17 13:46:45.000000000 +0100
++++ plib-1.8.5/src/net/Makefile.am 2008-04-17 13:54:12.000000000 +0100
+@@ -1,12 +1,14 @@
+ if BUILD_NET
+
+-lib_LIBRARIES = libplibnet.a
++lib_LTLIBRARIES = libplibnet.la
+
+ include_HEADERS = netBuffer.h netChannel.h netChat.h netMessage.h \
+ netMonitor.h netSocket.h net.h
+
+-libplibnet_a_SOURCES = netBuffer.cxx netChannel.cxx netChat.cxx \
++libplibnet_la_SOURCES = netBuffer.cxx netChannel.cxx netChat.cxx \
+ netMessage.cxx netMonitor.cxx netSocket.cxx
++libplibnet_la_LIBADD = ../util/libplibul.la
++libplibnet_la_LDFLAGS = -version-info 9:5:8
+
+ INCLUDES = -I$(top_srcdir)/src/util
+
+diff -Naur plib-1.8.5.orig/src/psl/Makefile.am plib-1.8.5/src/psl/Makefile.am
+--- plib-1.8.5.orig/src/psl/Makefile.am 2008-04-17 13:46:45.000000000 +0100
++++ plib-1.8.5/src/psl/Makefile.am 2008-04-17 14:13:43.000000000 +0100
+@@ -1,16 +1,18 @@
+
+ if BUILD_PSL
+
+-lib_LIBRARIES = libplibpsl.a
++lib_LTLIBRARIES = libplibpsl.la
+
+ include_HEADERS = psl.h
+
+-libplibpsl_a_SOURCES = psl.cxx pslCodeGen.cxx pslContext.cxx \
++libplibpsl_la_SOURCES = psl.cxx pslCodeGen.cxx pslContext.cxx \
+ pslCompiler.cxx pslSymbols.cxx pslToken.cxx \
+ pslExpression.cxx pslProgram.cxx pslDump.cxx \
+ pslError.cxx pslFileIO.cxx pslCompiler.h \
+ pslContext.h pslFileIO.h pslLocal.h \
+ pslOpcodes.h pslSymbol.h
++libplibpsl_la_LIBADD = ../util/libplibul.la
++libplibpsl_la_LDFLAGS = -version-info 9:5:8
+
+ INCLUDES = -I$(top_srcdir)/src/util
+
+diff -Naur plib-1.8.5.orig/src/puAux/Makefile.am plib-1.8.5/src/puAux/Makefile.am
+--- plib-1.8.5.orig/src/puAux/Makefile.am 2008-04-17 13:46:45.000000000 +0100
++++ plib-1.8.5/src/puAux/Makefile.am 2008-04-17 14:08:34.000000000 +0100
+@@ -1,10 +1,10 @@
+ if BUILD_PUAUX
+
+-lib_LIBRARIES = libplibpuaux.a
++lib_LTLIBRARIES = libplibpuaux.la
+
+ include_HEADERS = puAux.h puAuxLocal.h
+
+-libplibpuaux_a_SOURCES = puAux.cxx \
++libplibpuaux_la_SOURCES = puAux.cxx \
+ puAuxBiSlider.cxx \
+ puAuxBiSliderWithEnds.cxx \
+ puAuxComboBox.cxx \
+@@ -19,6 +19,9 @@
+ puAuxTriSlider.cxx \
+ puAuxVerticalMenu.cxx \
+ puAuxChooser.cxx
++libplibpuaux_la_LIBADD = ../util/libplibul.la ../pui/libplibpu.la \
++ ../fnt/libplibfnt.la ../sg/libplibsg.la
++libplibpuaux_la_LDFLAGS = -version-info 9:5:8
+
+ INCLUDES = -I$(top_srcdir)/src/sg \
+ -I$(top_srcdir)/src/pui \
+diff -Naur plib-1.8.5.orig/src/pui/Makefile.am plib-1.8.5/src/pui/Makefile.am
+--- plib-1.8.5.orig/src/pui/Makefile.am 2008-04-17 13:46:45.000000000 +0100
++++ plib-1.8.5/src/pui/Makefile.am 2008-04-17 14:09:12.000000000 +0100
+@@ -1,10 +1,10 @@
+ if BUILD_PUI
+
+-lib_LIBRARIES = libplibpu.a
++lib_LTLIBRARIES = libplibpu.la
+
+ include_HEADERS = pu.h puGLUT.h puFLTK.h puSDL.h puNative.h puPW.h
+
+-libplibpu_a_SOURCES = \
++libplibpu_la_SOURCES = \
+ pu.cxx puBox.cxx puButton.cxx puButtonBox.cxx \
+ puArrowButton.cxx puDialogBox.cxx puFrame.cxx puGroup.cxx \
+ puInput.cxx puInterface.cxx puLocal.h puMenuBar.cxx \
+@@ -14,6 +14,8 @@
+ puDial.cxx \
+ puRange.cxx \
+ puInputBase.cxx
++libplibpu_la_LIBADD = ../util/libplibul.la ../fnt/libplibfnt.la
++libplibpu_la_LDFLAGS = -version-info 9:5:8
+
+ AM_CPPFLAGS = -I$(top_srcdir)/src/sg -I$(top_srcdir)/src/fnt
+ AM_CPPFLAGS += -I$(top_srcdir)/src/util
+diff -Naur plib-1.8.5.orig/src/pw/Makefile.am plib-1.8.5/src/pw/Makefile.am
+--- plib-1.8.5.orig/src/pw/Makefile.am 2008-04-17 13:46:45.000000000 +0100
++++ plib-1.8.5/src/pw/Makefile.am 2008-04-17 14:13:46.000000000 +0100
+@@ -1,10 +1,11 @@
+ if BUILD_PW
+
+-lib_LIBRARIES = libplibpw.a
++lib_LTLIBRARIES = libplibpw.la
+
+ include_HEADERS = pw.h
+
+-libplibpw_a_SOURCES = pw.cxx pwX11.cxx pwWindows.cxx pwMacOSX.cxx
++libplibpw_la_SOURCES = pw.cxx pwX11.cxx pwWindows.cxx pwMacOSX.cxx
++libplibpw_la_LDFLAGS = -version-info 9:5:8
+
+ INCLUDES = -I$(top_srcdir)/src/util
+
+diff -Naur plib-1.8.5.orig/src/sg/Makefile.am plib-1.8.5/src/sg/Makefile.am
+--- plib-1.8.5.orig/src/sg/Makefile.am 2008-04-17 13:46:45.000000000 +0100
++++ plib-1.8.5/src/sg/Makefile.am 2008-04-17 14:14:23.000000000 +0100
+@@ -1,12 +1,14 @@
+ if BUILD_SG
+
+-lib_LIBRARIES = libplibsg.a
++lib_LTLIBRARIES = libplibsg.la
+
+ include_HEADERS = sg.h
+
+-libplibsg_a_SOURCES = sg.cxx sgd.cxx \
++libplibsg_la_SOURCES = sg.cxx sgd.cxx \
+ sgIsect.cxx sgdIsect.cxx \
+ sgPerlinNoise.cxx
++libplibsg_la_LIBADD = ../util/libplibul.la
++libplibsg_la_LDFLAGS = -version-info 9:5:8
+
+ INCLUDES = -I$(top_srcdir)/src/util
+
+diff -Naur plib-1.8.5.orig/src/sl/Makefile.am plib-1.8.5/src/sl/Makefile.am
+--- plib-1.8.5.orig/src/sl/Makefile.am 2008-04-17 13:46:45.000000000 +0100
++++ plib-1.8.5/src/sl/Makefile.am 2008-04-17 14:12:02.000000000 +0100
+@@ -1,16 +1,19 @@
+ if BUILD_SL
+
+-lib_LIBRARIES = libplibsl.a libplibsm.a
++lib_LTLIBRARIES = libplibsl.la libplibsm.la
+
+ include_HEADERS = sl.h slPortability.h sm.h
+
+-libplibsl_a_SOURCES = \
++libplibsl_la_SOURCES = \
+ slDSP.cxx slSample.cxx slEnvelope.cxx \
+ slPlayer.cxx slMODPlayer.cxx slSamplePlayer.cxx \
+ slScheduler.cxx slMODdacio.cxx slMODfile.cxx \
+ slMODinst.cxx slMODnote.cxx slMODPrivate.h slMODfile.h
++libplibsl_la_LIBADD = ../util/libplibul.la
++libplibsl_la_LDFLAGS = -version-info 9:5:8
+
+-libplibsm_a_SOURCES = slPortability.h smMixer.cxx
++libplibsm_la_SOURCES = slPortability.h smMixer.cxx
++libplibsm_la_LDFLAGS = -version-info 9:5:8
+
+ INCLUDES = -I$(top_srcdir)/src/util
+
+diff -Naur plib-1.8.5.orig/src/ssg/Makefile.am plib-1.8.5/src/ssg/Makefile.am
+--- plib-1.8.5.orig/src/ssg/Makefile.am 2008-04-17 13:46:45.000000000 +0100
++++ plib-1.8.5/src/ssg/Makefile.am 2008-04-17 14:15:18.000000000 +0100
+@@ -1,10 +1,10 @@
+ if BUILD_SSG
+
+-lib_LIBRARIES = libplibssg.a
++lib_LTLIBRARIES = libplibssg.la
+
+ include_HEADERS = ssg.h ssgconf.h ssgMSFSPalette.h ssgKeyFlier.h pcx.h
+
+-libplibssg_a_SOURCES = ssg.cxx ssgAnimation.cxx ssgBase.cxx \
++libplibssg_la_SOURCES = ssg.cxx ssgAnimation.cxx ssgBase.cxx \
+ ssgBaseTransform.cxx ssgBranch.cxx ssgContext.cxx ssgCutout.cxx \
+ ssgDList.cxx ssgEntity.cxx ssgIsect.cxx ssgLeaf.cxx ssgList.cxx \
+ ssgLoadDOF.cxx ssgLoadAC.cxx \
+@@ -28,6 +28,8 @@
+ ssgLoadMDL_BGLTexture.cxx ssgLoadXPlaneObj.cxx ssgLoadASC.cxx ssgSaveASC.cxx \
+ ssgSaveIV.cxx ssgAnimTransform.cxx\
+ ssgVertSplitter.h ssgVertSplitter.cxx ssgStatistics.cxx
++libplibssg_la_LIBADD = ../util/libplibul.la ../sg/libplibsg.la
++libplibssg_la_LDFLAGS = -version-info 9:5:8
+
+ INCLUDES = -I$(top_srcdir)/src/sg -I$(top_srcdir)/src/util
+
+diff -Naur plib-1.8.5.orig/src/ssgAux/Makefile.am plib-1.8.5/src/ssgAux/Makefile.am
+--- plib-1.8.5.orig/src/ssgAux/Makefile.am 2008-04-17 13:46:45.000000000 +0100
++++ plib-1.8.5/src/ssgAux/Makefile.am 2008-04-17 14:14:50.000000000 +0100
+@@ -1,6 +1,6 @@
+ if BUILD_SSGAUX
+
+-lib_LIBRARIES = libplibssgaux.a
++lib_LTLIBRARIES = libplibssgaux.la
+
+ include_HEADERS = ssgAux.h \
+ ssgaShapes.h \
+@@ -13,7 +13,7 @@
+ ssgaFire.h \
+ ssgaBillboards.h
+
+-libplibssgaux_a_SOURCES = ssgAux.cxx \
++libplibssgaux_la_SOURCES = ssgAux.cxx \
+ ssgaShapes.cxx \
+ ssgaPatch.cxx \
+ ssgaParticleSystem.cxx \
+@@ -30,6 +30,9 @@
+ ssgaSky.cxx \
+ ssgaTeapot.cxx \
+ ssgaBillboards.cxx
++libplibssgaux_la_LIBADD = ../util/libplibul.la ../ssg/libplibssg.la \
++ ../sg/libplibsg.la
++libplibssgaux_la_LDFLAGS = -version-info 9:5:8
+
+ INCLUDES = -I$(top_srcdir)/src/sg -I$(top_srcdir)/src/ssg
+ INCLUDES += -I$(top_srcdir)/src/util
+diff -Naur plib-1.8.5.orig/src/util/Makefile.am plib-1.8.5/src/util/Makefile.am
+--- plib-1.8.5.orig/src/util/Makefile.am 2008-04-17 13:46:45.000000000 +0100
++++ plib-1.8.5/src/util/Makefile.am 2008-04-17 14:13:41.000000000 +0100
+@@ -1,11 +1,12 @@
+ if BUILD_UL
+
+-lib_LIBRARIES = libplibul.a
++lib_LTLIBRARIES = libplibul.la
+
+ include_HEADERS = ul.h ulRTTI.h
+
+-libplibul_a_SOURCES = ul.cxx ulClock.cxx ulError.cxx ulLinkedList.cxx \
++libplibul_la_SOURCES = ul.cxx ulClock.cxx ulError.cxx ulLinkedList.cxx \
+ ulList.cxx ulLocal.h ulRTTI.cxx
++libplibul_la_LDFLAGS = -version-info 9:5:8
+
+ endif
+