summaryrefslogtreecommitdiff
path: root/user/pluma-plugins/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/pluma-plugins/APKBUILD')
-rw-r--r--user/pluma-plugins/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/user/pluma-plugins/APKBUILD b/user/pluma-plugins/APKBUILD
new file mode 100644
index 000000000..3f1e7b673
--- /dev/null
+++ b/user/pluma-plugins/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Síle Ekaterin Liszka <sheila@vulpina.house>
+# Maintainer: Síle Ekaterin Liszka <sheila@vulpine.house>
+pkgname=pluma-plugins
+pkgver=1.26.0
+pkgrel=0
+pkgdesc="Plugins for Pluma"
+url="https://www.mate-desktop.org"
+arch="all"
+license="GPL-2.0+"
+depends=""
+makedepends="itstool pluma-dev py3-pygobject vte-dev"
+subpackages="$pkgname-doc $pkgname-lang"
+source="https://pub.mate-desktop.org/releases/1.26/pluma-plugins-$pkgver.tar.xz"
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="ee59d52e0f879a5adf745c4be4a274f5c5b5403d7a9485236879e6e6db1c8f743de74be379fe84d2da73efe3eeb63bfa089a28f73762a6f0ceee0dbbbc464fa4 pluma-plugins-1.26.0.tar.xz"