summaryrefslogtreecommitdiff
path: root/user/pluma/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/pluma/APKBUILD')
-rw-r--r--user/pluma/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/user/pluma/APKBUILD b/user/pluma/APKBUILD
new file mode 100644
index 000000000..85fc97b63
--- /dev/null
+++ b/user/pluma/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+pkgname=pluma
+pkgver=1.22.1
+pkgrel=0
+pkgdesc="Text editor for the MATE desktop environment"
+url="https://mate-desktop.org"
+arch="all"
+options="!check" # tests fail due to schema being requested but not available
+license="GPL-2.0+ AND GPL-2.0-only AND LGPL-2.0+"
+depends=""
+makedepends="gtk+3.0-dev gtksourceview-3.0-dev enchant-dev intltool
+ itstool iso-codes-dev libpeas-dev libsm-dev libxml2-dev libxml2-utils"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+source="https://pub.mate-desktop.org/releases/${pkgver%.*}/pluma-$pkgver.tar.xz"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="0d3f07b2e8c736c9e1ad64ed5cb749db6088868e9bc27aa786cbb0c3fe72715f0fd4dd53999502a4333ec82110148b772c0dde81433d0936d2d3c2d04804026a pluma-1.22.1.tar.xz"