summaryrefslogtreecommitdiff
path: root/user/ppp/30_all_Makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'user/ppp/30_all_Makefile.patch')
-rw-r--r--user/ppp/30_all_Makefile.patch37
1 files changed, 0 insertions, 37 deletions
diff --git a/user/ppp/30_all_Makefile.patch b/user/ppp/30_all_Makefile.patch
deleted file mode 100644
index 165fc7b22..000000000
--- a/user/ppp/30_all_Makefile.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-Ensure that the build process aborts if there is an error in one of
-the plugin subdirectories.
-
-2010-09-01 Martin von Gagern
-
-References:
-http://bugs.gentoo.org/334727
-
-Index: ppp-2.4.5/pppd/plugins/Makefile.linux
-===================================================================
---- ppp-2.4.5/pppd/plugins/Makefile.linux
-+++ ppp-2.4.5/pppd/plugins/Makefile.linux
-@@ -20,7 +20,7 @@ include .depend
- endif
-
- all: $(PLUGINS)
-- for d in $(SUBDIRS); do $(MAKE) $(MFLAGS) -C $$d all; done
-+ for d in $(SUBDIRS); do $(MAKE) $(MFLAGS) -C $$d all || exit $?; done
-
- %.so: %.c
- $(CC) -o $@ $(LDFLAGS) $(CFLAGS) $^
-@@ -30,12 +30,12 @@ VERSION = $(shell awk -F '"' '/VERSION/
- install: $(PLUGINS)
- $(INSTALL) -d $(LIBDIR)
- $(INSTALL) $? $(LIBDIR)
-- for d in $(SUBDIRS); do $(MAKE) $(MFLAGS) -C $$d install; done
-+ for d in $(SUBDIRS); do $(MAKE) $(MFLAGS) -C $$d install || exit $?; done
-
- clean:
- rm -f *.o *.so *.a
-- for d in $(SUBDIRS); do $(MAKE) $(MFLAGS) -C $$d clean; done
-+ for d in $(SUBDIRS); do $(MAKE) $(MFLAGS) -C $$d clean || exit $?; done
-
- depend:
- $(CPP) -M $(CFLAGS) *.c >.depend
-- for d in $(SUBDIRS); do $(MAKE) $(MFLAGS) -C $$d depend; done
-+ for d in $(SUBDIRS); do $(MAKE) $(MFLAGS) -C $$d depend || exit $?; done