summaryrefslogtreecommitdiff
path: root/user/ppp/dhcp.patch
diff options
context:
space:
mode:
Diffstat (limited to 'user/ppp/dhcp.patch')
-rw-r--r--user/ppp/dhcp.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/user/ppp/dhcp.patch b/user/ppp/dhcp.patch
index 611882326..8ef76d2a0 100644
--- a/user/ppp/dhcp.patch
+++ b/user/ppp/dhcp.patch
@@ -322,3 +322,14 @@ diff -Naur ppp-2.4.7/pppd/plugins/dhcp.old/socket.h ppp-2.4.7/pppd/plugins/dhcp/
all: $(PLUGIN)
+--- ppp-ppp-2.4.8/pppd/plugins/dhcp/Makefile.linux.old 2020-02-26 04:02:43.528569753 +0000
++++ ppp-ppp-2.4.8/pppd/plugins/dhcp/Makefile.linux 2020-02-26 04:03:07.425957036 +0000
+@@ -14,7 +14,7 @@
+ $(INSTALL) -s -c -m 755 dhcpc.so $(LIBDIR)
+
+ dhcpc.so: dhcpc.o clientpacket.o packet.o socket.o options.o
+- $(CC) $(LDFLAGS) $(CFLAGS) -o $@ $^
++ $(CC) $(LDFLAGS) -shared $(CFLAGS) -o $@ $^
+
+
+ clean: