summaryrefslogtreecommitdiff
path: root/user/py3-alabaster/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/py3-alabaster/APKBUILD')
-rw-r--r--user/py3-alabaster/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/user/py3-alabaster/APKBUILD b/user/py3-alabaster/APKBUILD
new file mode 100644
index 000000000..65356c103
--- /dev/null
+++ b/user/py3-alabaster/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Brandon Bergren <git@bdragon.rtk0.net>
+# Maintainer: Brandon Bergren <git@bdragon.rtk0.net>
+pkgname=py3-alabaster
+_pkgname=alabaster
+pkgver=0.7.12
+pkgrel=0
+pkgdesc="Default theme for Sphinx Documentation Generator"
+url="https://pypi.python.org/pypi/alabaster"
+arch="noarch"
+# Inexact match, due to being derived work of a theme.
+license="BSD-3-Clause"
+depends="python3 py3-pygments"
+makedepends="python3-dev"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ # Zero tests currently.
+ python3 setup.py test
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+
+}
+
+sha512sums="e3bfd0c92ce01f08d5e6d9dc1ef0967ca1f54827e08756f4a0ba7be8d3b8bec7f2e53a169b831ff5ce2d2548f7f52c6e518bcc513e49bb3e4c38274293aebbac py3-alabaster-0.7.12.tar.gz"