summaryrefslogtreecommitdiff
path: root/user/py3-chardet/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/py3-chardet/APKBUILD')
-rw-r--r--user/py3-chardet/APKBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/user/py3-chardet/APKBUILD b/user/py3-chardet/APKBUILD
index f33618402..e9d6fce3f 100644
--- a/user/py3-chardet/APKBUILD
+++ b/user/py3-chardet/APKBUILD
@@ -10,23 +10,27 @@ pkgrel=0
pkgdesc="The Universal Character Encoding Detector"
url="https://github.com/chardet/chardet/"
arch="noarch"
-options="!check" # tests use hypothesis; deep rabbit hole
license="LGPL-2.1-only"
depends="python3"
+checkdepends="py3-hypothesis py3-pytest"
makedepends="python3-dev"
subpackages=""
-source="https://files.pythonhosted.org/packages/source/$_p/$_pkgname/$_pkgname-$pkgver.tar.gz"
+source="https://files.pythonhosted.org/packages/source/$_p/$_pkgname/$_pkgname-$pkgver.tar.gz
+ pytest.patch
+ "
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$builddir"
python3 setup.py build
}
+check() {
+ python3 setup.py test
+}
+
package() {
- mkdir -p "$pkgdir"
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
}
-sha512sums="61a03b23447a2bfe52ceed4dd1b9afdb5784da1933a623776883ee9f297e341f633e27f0ce0230bd5fdc5fdb5382105ab42736a74a417ddeb9f83af57455dba5 chardet-3.0.4.tar.gz"
+sha512sums="61a03b23447a2bfe52ceed4dd1b9afdb5784da1933a623776883ee9f297e341f633e27f0ce0230bd5fdc5fdb5382105ab42736a74a417ddeb9f83af57455dba5 chardet-3.0.4.tar.gz
+57bfeb5752123fbf9f9f61386039b7ceb9255290225f73453d2d52f2366e1949ed92692912571c8b451b521aedfa8b605879b2742aec7f1fdce4db10705cbe53 pytest.patch"