summaryrefslogtreecommitdiff
path: root/user/py3-iniconfig/version.patch
diff options
context:
space:
mode:
Diffstat (limited to 'user/py3-iniconfig/version.patch')
-rw-r--r--user/py3-iniconfig/version.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/user/py3-iniconfig/version.patch b/user/py3-iniconfig/version.patch
new file mode 100644
index 000000000..33bf819cf
--- /dev/null
+++ b/user/py3-iniconfig/version.patch
@@ -0,0 +1,23 @@
+From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
+Date: Sun, 12 Jun 2022 22:48:18 -0500
+Subject: [PATCH] Use correct version when packaging
+
+Using scm_version installs an egg of version 0.0.0 (or whatever the
+containing Git repository describes as). We want to have the actual
+version available when building packages.
+
+--- iniconfig-1.1.1/setup.py.old 2020-10-14 05:19:54.000000000 -0500
++++ iniconfig-1.1.1/setup.py 2022-06-12 22:52:45.840000000 -0500
+@@ -14,11 +14,11 @@
+ readme = fp.read()
+ setup(
+ name='iniconfig',
++ version='1.1.1',
+ packages=['iniconfig'],
+ package_dir={'': 'src'},
+ description='iniconfig: brain-dead simple config-ini parsing',
+ long_description=readme,
+- use_scm_version=True,
+ url='http://github.com/RonnyPfannschmidt/iniconfig',
+ license='MIT License',
+ platforms=['unix', 'linux', 'osx', 'cygwin', 'win32'],