summaryrefslogtreecommitdiff
path: root/user/py3-olefile
diff options
context:
space:
mode:
Diffstat (limited to 'user/py3-olefile')
-rw-r--r--user/py3-olefile/APKBUILD4
1 files changed, 1 insertions, 3 deletions
diff --git a/user/py3-olefile/APKBUILD b/user/py3-olefile/APKBUILD
index c44ee5842..a890d231f 100644
--- a/user/py3-olefile/APKBUILD
+++ b/user/py3-olefile/APKBUILD
@@ -11,21 +11,19 @@ arch="noarch"
license="BSD-2-Clause AND Custom"
depends="python3"
makedepends="python3-dev unzip"
+subpackages=""
source="$pkgname-$pkgver.zip::https://files.pythonhosted.org/packages/source/o/$_pkgname/$_pkgname-$pkgver.zip"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$builddir"
python3 setup.py build
}
check() {
- cd "$builddir"
PYTHONPATH="build/lib" python3 tests/test_olefile.py
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
}