summaryrefslogtreecommitdiff
path: root/user/py3-pluggy/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/py3-pluggy/APKBUILD')
-rw-r--r--user/py3-pluggy/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/user/py3-pluggy/APKBUILD b/user/py3-pluggy/APKBUILD
new file mode 100644
index 000000000..b71d8de07
--- /dev/null
+++ b/user/py3-pluggy/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Max Rees <maxcrees@me.com>
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname=py3-pluggy
+_pkgname=pluggy
+pkgver=0.6.0
+pkgrel=0
+pkgdesc="Plugin management and hook calling for Python"
+url="https://pypi.python.org/pypi/pluggy"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="python3-dev py3-setuptools"
+#checkdepends="py3-tox"
+options="!check" # Cyclic dependency with py3-tox. Passes on x86_64
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ tox -e py36-pytestrelease
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="dd58dabe2e65eee64d62c8748c2bbd99457288e99b819eb12312f2acdb0740ac46fd08f83522bc992297b9f14eec14c216c2c9688580f68393bf6fc609e65812 py3-pluggy-0.6.0.tar.gz"