summaryrefslogtreecommitdiff
path: root/user/py3-ply
diff options
context:
space:
mode:
Diffstat (limited to 'user/py3-ply')
-rw-r--r--user/py3-ply/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/user/py3-ply/APKBUILD b/user/py3-ply/APKBUILD
new file mode 100644
index 000000000..495a66d53
--- /dev/null
+++ b/user/py3-ply/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=py3-ply
+pkgver=3.11
+pkgrel=0
+pkgdesc="lex(1) and yacc(1) parser in Python"
+url="http://www.dabeaz.com/ply/"
+arch="noarch"
+license="BSD-3-Clause"
+depends="python3"
+makedepends="python3-dev"
+subpackages=""
+source="http://www.dabeaz.com/ply/ply-$pkgver.tar.gz"
+builddir="$srcdir/ply-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py check
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="37e39a4f930874933223be58a3da7f259e155b75135f1edd47069b3b40e5e96af883ebf1c8a1bbd32f914a9e92cfc12e29fec05cf61b518f46c1d37421b20008 ply-3.11.tar.gz"