summaryrefslogtreecommitdiff
path: root/user/py3-pretend/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/py3-pretend/APKBUILD')
-rw-r--r--user/py3-pretend/APKBUILD5
1 files changed, 1 insertions, 4 deletions
diff --git a/user/py3-pretend/APKBUILD b/user/py3-pretend/APKBUILD
index 87ba1cdf6..5a7b8e175 100644
--- a/user/py3-pretend/APKBUILD
+++ b/user/py3-pretend/APKBUILD
@@ -12,23 +12,20 @@ arch="noarch"
options="!check" # Test script missing from tarball
license="BSD-3-Clause"
depends="python3"
-makedepends="python3-dev"
checkdepends="py3-pytest"
+makedepends="python3-dev"
source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/$_p/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$builddir"
python3 setup.py build
}
check() {
- cd "$builddir"
python3 test_pretend.py
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}