summaryrefslogtreecommitdiff
path: root/user/py3-pyang/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'user/py3-pyang/APKBUILD')
-rw-r--r--user/py3-pyang/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/user/py3-pyang/APKBUILD b/user/py3-pyang/APKBUILD
new file mode 100644
index 000000000..6ac07ef7f
--- /dev/null
+++ b/user/py3-pyang/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=py3-pyang
+_pkgname=pyang
+_p="${_pkgname#?}"
+_p="${_pkgname%"$_p"}"
+pkgver=2.3.2
+pkgrel=0
+pkgdesc="YANG tooling for Python"
+url="https://pypi.org/project/pyang/"
+arch="noarch"
+license="ISC"
+depends="python3 py3-lxml"
+makedepends=""
+subpackages="$pkgname-doc $pkgname-bash-completion:bashcomp"
+source="https://files.pythonhosted.org/packages/source/$_p/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/pyang-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+bashcomp() {
+ pkgdesc="$pkgdesc (Bash completions)"
+ depends="py3-pyang"
+ install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
+
+ mkdir "$subpkgdir"
+ mv "$pkgdir"/usr/etc "$subpkgdir"/
+}
+
+sha512sums="11f4e0531bea85eab63bf20c4ee785e24c81988333abb90a9ab076704fde8617eaa12f8b3f6f162ddbb4f83ffc2d20b9941311a529b296c198cb2ecd665ad63f pyang-2.3.2.tar.gz"