summaryrefslogtreecommitdiff
path: root/user/py3-pycairo/meson-idiocy.patch
diff options
context:
space:
mode:
Diffstat (limited to 'user/py3-pycairo/meson-idiocy.patch')
-rw-r--r--user/py3-pycairo/meson-idiocy.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/user/py3-pycairo/meson-idiocy.patch b/user/py3-pycairo/meson-idiocy.patch
new file mode 100644
index 000000000..99ed7d71c
--- /dev/null
+++ b/user/py3-pycairo/meson-idiocy.patch
@@ -0,0 +1,27 @@
+From 878932bf9c1545d659822961459a2601287b1675 Mon Sep 17 00:00:00 2001
+From: Christoph Reiter <reiter.christoph@gmail.com>
+Date: Sat, 23 Mar 2019 22:26:01 +0100
+Subject: [PATCH] meson: fix configure error with meson 0.50 re absolute paths.
+ Fixes #144
+
+The newest meson version has started to fail:
+meson.build:62:0: ERROR: Subdir keyword must not be an absolute path.
+
+Fix by using install_dir instead of subdir.
+---
+ cairo/meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/cairo/meson.build b/cairo/meson.build
+index 6a1bde3..3e3b2cc 100644
+--- a/cairo/meson.build
++++ b/cairo/meson.build
+@@ -61,7 +61,7 @@ header_file = configure_file(
+
+ install_headers(
+ [header_file],
+- subdir: join_paths(python.get_install_dir(), 'cairo', 'include'),
++ install_dir: join_paths(python.get_install_dir(), 'cairo', 'include'),
+ )
+ install_headers([header_file], subdir: 'pycairo')
+